Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

New ride...

Discussion in 'The Garage' started by Confedneck79K30, Apr 1, 2007.

  1. Confedneck79K30

    Confedneck79K30 3/4 ton status

    Joined:
    Oct 1, 2006
    Posts:
    5,384
    Likes Received:
    0
    Location:
    LA
    picked this up today from a customer of mine...
    retard lost the title and forgot to leave the keys when he dropped it off

    95 sblazer 4.3 4 door 4x4
    ill know miles later lol
    washed it today, in pretty nice shape, needs some buffing and the hood repainted
    wont go over 55.. any ideas? im gonna check the cat first...

    95blaz.JPG

    95blaz2.JPG

    95blaz3.JPG

    fleet.JPG
     
  2. Craig Artzner

    Craig Artzner 3/4 ton status GMOTM Winner

    Joined:
    Dec 16, 2006
    Posts:
    6,843
    Likes Received:
    0
    Location:
    Northeast Ohio
    What's that tarp doing on the back? Diaper? :( :D
     
  3. Clod_King

    Clod_King 1/2 ton status

    Joined:
    Jun 7, 2005
    Posts:
    1,094
    Likes Received:
    0
    Location:
    Grimsby Ontario
    I think it's the cape...:haha:
     
  4. Dudge

    Dudge 1/2 ton status

    Joined:
    Sep 9, 2006
    Posts:
    351
    Likes Received:
    0
    Location:
    Kentucky
    I'm pretty sure you're not going to like the mileage it gets. Lol I hate it. I have a '99 2wd S-10. 4.3/auto. It's a stepside. The thing is light as can be. It gets about 14-15 mpg. With the factory tune in the comp it gets 13. My brother has a '00 ZR2 Blazer and it also gets terrible mileage. Just throwing that out there. It looks pretty sharp though.
     
  5. SkysTheLimit

    SkysTheLimit 1/2 ton status

    Joined:
    May 23, 2003
    Posts:
    530
    Likes Received:
    0
    Location:
    Tampa, FL
    First thing I'd check is if there's a screw driver in the ignition... :haha::haha:
     
  6. vortec

    vortec 1/2 ton status

    Joined:
    Jul 22, 2004
    Posts:
    1,472
    Likes Received:
    0
    Location:
    fort worth, texas
    everyone i know with an s10 gets decent (not amazing) mpg.

    my friend's 2001 s10 has the 4.3L, manual tranny and zq8 suspension and he gets low 20s in mixed city/highway, and he drives like a freaking maniac.

    my mom's 2000 s10 blazer 4dr 2wd gets about 18 city, 21 highway.
     
  7. 01maroonz71

    01maroonz71 1/2 ton status

    Joined:
    Jan 8, 2007
    Posts:
    1,553
    Likes Received:
    4
    Location:
    Palmetto, fl
    i thought you were tryin to get rid of your extra trucks...haha....nice find though man, crank the tbars, throw a body lift and some 31's on her....looks just like my buddies, whom we put 31LTB's on it, and it went ALOT of places my big heavy fullsize couldn't.
     
  8. Confedneck79K30

    Confedneck79K30 3/4 ton status

    Joined:
    Oct 1, 2006
    Posts:
    5,384
    Likes Received:
    0
    Location:
    LA
    its getting 31s no bl... gotta make it run right first... the tarp is because it doesnt have a tag lol and the cockface across the canal will call code.. so til i sell my dually, it has no tag...

    but here goes the tech part

    i drove it last night, the cat's already out of it and the muffler's rotted... when you stomp on it, it stumbles a little then takes off like a bat outta hell... map sensor? maf sensor? tp sensor? gotta look into it this weekend, any ideas?
     
  9. Confedneck79K30

    Confedneck79K30 3/4 ton status

    Joined:
    Oct 1, 2006
    Posts:
    5,384
    Likes Received:
    0
    Location:
    LA
    alrighty gurus... this thing doesnt have a MAF sensor, but it does have a MAP sensor, i think...
    cleaned out the EGR and iac valve, cleaned out the intake, and took out the clogged solid k/n and cleaned it and dropped it back in... replaced the muffler with a 40 series and a turn down.
    still has that nasty stumble off idle, doesnt matter wot or partial...
    first gear starts, 2nd gear starts, starting in drive... doesnt matter, seems like it clears up above certain rpms (no tach)... but it does scream once it gets going... any ideas?
     
  10. iwaxmyjimmy

    iwaxmyjimmy College web wheeler Premium Member

    Joined:
    Nov 3, 2006
    Posts:
    2,802
    Likes Received:
    34
    Location:
    Greenville NC
    How is it starting wise? little rough but starts or starts right up? Wish it was OBD II so you could plug in a tech 2 and see the DTC history.
     
  11. Confedneck79K30

    Confedneck79K30 3/4 ton status

    Joined:
    Oct 1, 2006
    Posts:
    5,384
    Likes Received:
    0
    Location:
    LA
    starts right up...
    its obd1, soon as i get a new scanner in stock, ill hook it up
     
  12. iwaxmyjimmy

    iwaxmyjimmy College web wheeler Premium Member

    Joined:
    Nov 3, 2006
    Posts:
    2,802
    Likes Received:
    34
    Location:
    Greenville NC
    Prob. the best part about being a snap-on dealer huh? lol
     
  13. dhcomp

    dhcomp 3/4 ton status Premium Member

    Joined:
    Mar 17, 2001
    Posts:
    9,862
    Likes Received:
    294
    Location:
    Truckee, CA
    this prolly sounds dumb, but you check teh fuel filter?
     

Share This Page