Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

New to this group and need your HELP

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Liftinstall, Jan 5, 2006.

  1. Liftinstall

    Liftinstall Newbie

    Joined:
    Jan 5, 2006
    Posts:
    1
    Likes Received:
    0
    Location:
    Diamond Bar, CA
    Hey Everyone,

    I just bought a 73 K5 Blazer 4x4 with the factory 350 CI and Turbo 350 trans.

    I noticed a leak in my trans when i put it in reverse, I thought it was coming from the Vacume valve on the rear passanger side. But tonight I found a hair line crack going from the passanger side rear pan bolt and up about 2 inches it is only leaking in reverse but when in reverse its a good leak.

    Has anyone else had a cracked case? can it be fixed or do i have to replace the case or complete trans? I am new to the 4x4 stuff so bear with me as I learn.

    Also does anyone know if this is a common thing or one in a million.

    Thanks Rob
     
  2. pauly383

    pauly383 Daddy383 Staff Member Moderator

    Joined:
    Jul 22, 2001
    Posts:
    16,217
    Likes Received:
    1
    Location:
    Mesa , Arizona USA
    I would be saving for another one in the future anyway .

    In the meantime maybe find out why it cracked . Does your truck has any support of the rear of the transfercase , the mount on the side to the frame ? Are all the bellhousing bolts tight ? Motor and tranny mounts ok ?

    Myself , I would probably check into someone welding it or something and drive it until it dies , maybe even jb weld , but then again , I have another ride to work if it blew up , and wouldn't want to spend money if the tranny was otherwise perfect :ignore:
     
  3. mouse

    mouse 1/2 ton status

    Joined:
    Nov 10, 2003
    Posts:
    1,448
    Likes Received:
    0
    Location:
    Great Falls Mt
    350 trannies are pretty cheap around here. I would try to find a cheap replacement. Rebuilds for them usually dont go for too much.
     
  4. roadnotca

    roadnotca 3/4 ton status

    Joined:
    Sep 16, 2005
    Posts:
    5,433
    Likes Received:
    1
    Location:
    Redondo Beach, CA
    A picture of where you're talking about, would help. From the sound of it, something must be flexing if it opens only when reversing.
     
  5. blackblazer717

    blackblazer717 1/2 ton status

    Joined:
    Jul 1, 2004
    Posts:
    470
    Likes Received:
    0
    Location:
    massachusetts
    it sounds to me like a bad mount or something caused it, because if the crack gets bigger and leaks more in reverse than something is flexing to cause it to leak, look around and find whats worn, replace that than JB the crack up

    LUKE
     

Share This Page