Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

new tranny now a loud bang

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by chevycanada, Nov 2, 2001.

  1. chevycanada

    chevycanada Registered Member

    Joined:
    Aug 14, 2001
    Posts:
    33
    Likes Received:
    0
    Location:
    Comox BC
    i just put a new transmission in my jimmy. i put in the tranny and new touque converter. i got it all together and ran fine for about an hour. now there is a loud banging sound coming from between the rear of the engine and the tranny, right by the torque converter. it is there at idle and speeds up as you accelerate. i can't figure out what it is.
    any help would be greatly appreciated.
    i wanted to go wheelin this weekend but its not lookin so good now.
     
  2. wayne

    wayne 3/4 ton status

    Joined:
    Feb 1, 2001
    Posts:
    6,178
    Likes Received:
    0
    Location:
    Carlisle, Pa
    Check your converter bolts and make sure they are all tight.

    See <a target="_blank" href=http://coloradok5.com/gallery/Waynes-Toy>Project Mighty Mouse</a> here.
    <font color=blue>Wayne<font color=blue>
    <font color=blue>Happy Trails<font color=blue>
     
  3. Msquared

    Msquared Registered Member

    Joined:
    Oct 2, 2001
    Posts:
    37
    Likes Received:
    0
    Location:
    It\'s all a fog
    Yup, sounds like loose convertor bolts or flexplate bolts. Hope for the loose convertor bolts....:)

    -Marcus
    -Just me, trying to have fun
     
  4. newyorkin

    newyorkin 1 ton status

    Joined:
    May 8, 2001
    Posts:
    16,555
    Likes Received:
    157
    Location:
    Los Estados Unitos
    Yeah, convertor or bellhousing.. Check it soon, too!

    Ratch
    <a target="_blank" href=http://k5.8m.com>k5.8m.com</a>
    Welcome to America.
     
  5. Executioner

    Executioner 1/2 ton status

    Joined:
    Feb 22, 2000
    Posts:
    1,530
    Likes Received:
    0
    Location:
    Temp. Ft. Walton Beach Fl. home=Tucson, Az.
    Something is fishie, new torque converter ???
    Then new Tranny ????
    What if they include an free tranny.................................
    small print buy one get one free
     
  6. Leadfoot

    Leadfoot 1/2 ton status Premium Member

    Joined:
    Nov 28, 2000
    Posts:
    3,112
    Likes Received:
    1
    Location:
    Western Massachusetts
    Happened to me once. It turned out to be a blown converter and sent metal particles throughout the tranny. I could still drive it, but it made that sound. Eventually so much metal got in the valve body it wouldn't shift out of first. If it makes the noise in gear (forward or reverse) but not in Neutral or Park, this COULD be your problem. If it is, it's not going to be fun.

    See my rig at <a target="_blank" href=http://coloradok5.com/gallery/Leadfoot>http://coloradok5.com/gallery/Leadfoot</a>
     

Share This Page