Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Newbie NP 203 Questions

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by 96texasz, Dec 24, 2006.

  1. 96texasz

    96texasz Registered Member

    Joined:
    Nov 13, 2006
    Posts:
    28
    Likes Received:
    0
    Location:
    Wichita Falls, TX
    my new blazer has the np 203 and the guy i bought it from said that it is all time 4wd is this true? I stuck it in to 4lo yesterday and when i tried to put the case back into drive it stuck in neutral and took forever to get back in. I called the guy and he said it hadn't been in 4wd in over a year so did i just need to bust it loose or does this sound like a linkage problem? Also it would pop out of 4lo sometimes too
     
  2. Cricket

    Cricket 3/4 ton status

    Joined:
    Nov 29, 2004
    Posts:
    8,224
    Likes Received:
    0
    Location:
    Colorado
  3. 96texasz

    96texasz Registered Member

    Joined:
    Nov 13, 2006
    Posts:
    28
    Likes Received:
    0
    Location:
    Wichita Falls, TX
    thanks
     
  4. Cricket

    Cricket 3/4 ton status

    Joined:
    Nov 29, 2004
    Posts:
    8,224
    Likes Received:
    0
    Location:
    Colorado
    Your welcome, if you have any more questions just ask and someone will try and help you.
     
  5. AZ79K5Project

    AZ79K5Project 1/2 ton status

    Joined:
    Jan 15, 2006
    Posts:
    2,082
    Likes Received:
    0
    Location:
    Arizona
    One more thing, once the 203 shifter dries out it doesn't move very well. Try spraying some lubricant up into the shifter. Stay away from lithium grease. It drys out after some time and leaves back at square one.
     

Share This Page