Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Newly purchased 77 k5 tranny toasted?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by firsttimeblazer, Mar 30, 2001.

  1. firsttimeblazer

    firsttimeblazer Registered Member

    Joined:
    Mar 29, 2001
    Posts:
    18
    Likes Received:
    0
    Location:
    southern california
    My first blazer 77 k5(had once 71 bronco some 18 years ago)
    so in essence all this tech stuff is a new challenge. Basically i am going to try to become a weekend mechanic again. The enigne runs strong and when i purchased the tranny it just slipped a little when going into a high gear or hesitated a better word. i got a prety good deal so i went for it. now a week later it barely moves in to gear. A friend told me that the guy i bought it from probably put brake fluid or something in the tranyy to which helped get it going while i test drove? I have no clue but i guess i need a rebuild? any feed back.
     
  2. POWERMAD

    POWERMAD 1/2 ton status

    Joined:
    Mar 4, 2001
    Posts:
    3,466
    Likes Received:
    0
    Location:
    Oregon
    Break out the check book.
    I spent $860 to have the Th400 in my 73 C20 rebuilt.
    That came with a B&M stage 2 kit and a deep pan.
    With the 463 plant you almost need a head restraint when you take off at WOT.
    Good luck
    See ya

    my truck's not dirty, it's earth tone paint
     

Share This Page