Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

No 4th gear with Corvette Servo --what's wrong?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Blue85b, Mar 9, 2001.

  1. Blue85b

    Blue85b Registered Member

    Joined:
    Mar 5, 2001
    Posts:
    22
    Likes Received:
    0
    No 4th gear with Corvette Servo --what\'s wrong?

    There's no better way to spend your Friday night than upgrading the K-5, right? Well, I've had a bit of a 2-3 shift flare-up after my transmission rebuild and when I called B&M, they confirmed my suspiscion: my valve body is now calibrated for use with the Vette Servo. (The Vette servo applies the 2-4 band harder, but also releases slower. My tranny was now releasing the band too quickly on the 2-3 upshift, allowing some flare before the 3-4 clutch was engaged.) So I bought myself a 2nd gear apply piston and housing in the 1.78" diameter to replace my stock 2.28" diameter one. The install was really easy since I have a drain plug. Now my 1-2 shift is good and my 2-3 flare-up is gone, but I can't seem to get a 3-4 shift. Obviously, this is a TH700R-4. Fluid level seems fine.

    The only idea that I have is that 4th gear pressure is leaking past the seal between the 4th gear apply piston and the servo cover. When I had the servo apart, I noticed that this fit was a bit loose. Maybe it was about to stop shifting in OD before because of this and the change in piston size aggravated the situation. This was the only seal that I didn't have a replacement handy for. Does this sound like a valid theory?

    Are there any other ideas? If I wan'ted a 3-speed, I should have used a 350...
     
  2. corvette6

    corvette6 Registered Member

    Joined:
    Mar 9, 2001
    Posts:
    12
    Likes Received:
    0
    Re: No 4th gear with Corvette Servo --what\'s wrong?

    Sounds like your way above my head. I'm having problems with my 700 spraying fluid out when towing. Can I make this tranny work for towing or should i toss it for a 3 speed?
     
  3. Blue85b

    Blue85b Registered Member

    Joined:
    Mar 5, 2001
    Posts:
    22
    Likes Received:
    0
    Re: No 4th gear with Corvette Servo --what\'s wrong?

    corvette6,
    We'll cover your transmission problems in your thread...

    Anyone else have experience with the Vette servo or servo problems in general?
     
  4. Blazer_Boy

    Blazer_Boy 1/2 ton status

    Joined:
    Dec 16, 2000
    Posts:
    1,669
    Likes Received:
    0
    Location:
    Sioux City, IA, USA
    Re: No 4th gear with Corvette Servo --what\'s wrong?

    momma-me-a, you make me feel like a know nothing retard. After I took my T-Case apart and resealed, I felt all smart, not anymore! Just thought I'd like to share.
     
  5. corvette6

    corvette6 Registered Member

    Joined:
    Mar 9, 2001
    Posts:
    12
    Likes Received:
    0
    Re: No 4th gear with Corvette Servo --what\'s wrong?

    Thanks for your help
     
  6. mudfanatic

    mudfanatic 1/2 ton status

    Joined:
    Feb 18, 2000
    Posts:
    614
    Likes Received:
    0
    Location:
    Aloha, Oregon
    Re: No 4th gear with Corvette Servo --what\'s wrong?

    UMMM, I , ummm, well, I used to think that I knew a little about auto tranny's but I just learned a lot.
    Actually from what you explained it sounds like your theory is right on. Pull the 4th gear apply piston and get a new seal for it and your problems should be cured.
    Dan
    sold the Blazer

    <font color=red>get involved with land issues or lose the land</font color=red>
     
  7. Blue85

    Blue85 Troll Premium Member

    Joined:
    Jul 26, 2000
    Posts:
    9,086
    Likes Received:
    487
    Location:
    Grand Rapids area
    Re: No 4th gear with Corvette Servo --what\'s wrong?

    Well...strangely enough it works today. I couldn't get it to drop in to OD on the highway last night, but this morning on the freeway everything worked perfectly. Maybe it just needed to get the oil back into everything in the valve body? I don't know, they usually work fine right after a fluid change. I may still change that seal and if that doesn't seem tight, I may get a new 4th apply piston and servo cover.

    I'm still curious if anyone else has had a similar experience.

    <font color=green>Stupid tourist at Mammoth Cave, Kentucky: "How many miles of unexplored passages are there?"</font color=green>
     
  8. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,980
    Likes Received:
    189
    Location:
    Roy WA
    Re: No 4th gear with Corvette Servo --what\'s wrong?

    Had a problem with my Th400 ONCE right after I rebuilt it. Wouldn't upshift from 2nd anymore. So I started manually shifting through all forward gears. Many, many times. That fixed it. Supposedly a particle wedged in the governor can cause it to stick. Rowing through gears somehow can help that, and did in my case. After that, it never occurred again. Even a tranny guy told me that was the "correct" procedure.

    Dorian
    My K5 and Chev/Olds tech/links page: <A target="_blank" HREF=http://www.dorianyeager.com/index2.html>http://www.dorianyeager.com/index2.html</A>
     

Share This Page