Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

No brake lights, no turn signals?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by mountainexplorer, Nov 20, 2003.

  1. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    Everything works except I dont have brake lights or turn signals. Flasher is good. Fuses are good. Bulbs are good. 4-Way flashers work. Whats left? (this happened all of a sudden)
     
  2. emoo99

    emoo99 1/2 ton status

    Joined:
    Jan 16, 2003
    Posts:
    494
    Likes Received:
    0
    Location:
    Washington
    probably a gound somewhere,, check your headlight switch,, my switch grounds out to the dash, make sure you twist the back of the switch and make sure it's tight against the metal of the dash, that's how it is in mine anyways..
     
  3. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    All my park lights and headlights work, just no brake lights. Tried fiddling with things and turn signals work, just no brake lights. I'm going to try changing the brake light switch that mounts above the pedal.
     
  4. K10ANDYKHAMNIC

    K10ANDYKHAMNIC 1/2 ton status

    Joined:
    Sep 17, 2001
    Posts:
    1,962
    Likes Received:
    0
    Location:
    Western CO
    same thing happenend to me it was a fuse , did you test the fuse ? it was fixed but now my backups wont work i think its a ground somewhere . .... <shrug>
     
  5. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    I checked every fuse in the fuse box, and none were visibly burnt out. Arent the brake and emergency flashers on the same fuse? cause the flashers work.
     
  6. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    try another light switch,

    i had no hazards or brake lights in the 83, it was nust burnt fuse, probably happened some time before truck was parked, around 5 years ago, i had alot of bulbs to replace too, i still need to spray sockets with oil yet, and grease them too.
    one of these days,,.


    i dont know what else that you could check with missing turns and brakes, hmm.. no turn lights at all anywhere, not a one not evne in dash ?


    trace the rear lights harness from firewall down and back along frame rail, and check connections and splices out under tail of bed too, make sure have grounds at lights too back there



    hmm..
     
  7. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    Got it figured out last night when I went to tow a rig with the truck. Turn signals were working, flashers were working, just no brake lights. Narrowed it down to the little switch that mounts above the brake pedal, that actuates the lights when the pedal is depressed. I switched that out and they worked.
     

Share This Page