Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

No forward gears only low gear

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Zepplin, Jun 18, 2001.

  1. Zepplin

    Zepplin 1/2 ton status

    Aug 29, 2000
    Likes Received:
    Bay City, MI 48706
    I toasted my tranny this weekend. At first I could drive it without any problems I just had to shift it manually from the steering column. But, now I only have low gear and when I put it in drive or in second it sounds like its in Neutral.

    I checked the fluid and its a burnt color and it smells burnt.
    Its probably my clutches and a few sprags. Its a TH350 by the way. Could it be anything else internally wrong or just burnt clutches.

    I don't plan on fixing it at the moment because I have a 496 waiting to get put in but, I need to find a 400 and a 205 first.

    I just thought I would share with everyone that I will be Blazer-less for the rest of the summer. I will save some money on gas now though! :)

    74 Blazer
    Check out my Blazer <A target="_blank" HREF=http://community.webshots.com/user/zepplin1976>http://community.webshots.com/user/zepplin1976</A>
  2. muddin4fun

    muddin4fun 3/4 ton status

    Feb 19, 2001
    Likes Received:
    N Texas
    If yer gonna pull it and open it anyway, I'd just rebuild the whole thing.

    <font color=purple>Have you hugged your K5 today?</font color=purple>

Share This Page