Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

no gass no go! help!

Discussion in 'The Garage' started by mightywhitey_k5, Feb 4, 2005.

  1. mightywhitey_k5

    mightywhitey_k5 Registered Member

    Joined:
    Sep 3, 2004
    Posts:
    74
    Likes Received:
    0
    My 87 K5 is getting gas all the way up to the throttle body but is not spittion out the injectors. I have replaced the distributor control mod. like someone on the forum had sugested but no help. any other sugestions.
     
  2. blazerguy 90

    blazerguy 90 1/2 ton status

    Joined:
    Nov 12, 2004
    Posts:
    126
    Likes Received:
    0
    Location:
    EL Sobrante, CA
    No Fuel

    Check your fuses, you could have a blown ecm fuse, are you sure that the fuel pump is working ?, can you hear it run when you turn the key on ?.
     
  3. 3 on the tree

    3 on the tree 1/2 ton status

    Joined:
    Oct 16, 2004
    Posts:
    3,970
    Likes Received:
    0
    Location:
    gunnison colorado
    Ran across this once. The spacer tween the tbi and the iar cleaner had pinched and shorted out the hot wire to the tbi, kept blowing fuses. Taped the wire up, put the spacer on correctly, new fuse and away she went
     
  4. Hossbaby50

    Hossbaby50 3/4 ton status

    Joined:
    Sep 1, 2001
    Posts:
    8,972
    Likes Received:
    0
    Location:
    Peoria, AZ
    Get a NOID light from your local parts house and use it to check and see if the injectors are getting the signal to fire from the ECM. This will tell you if the problem is in the injectors or if it is in the electrical system. You got to know where the problem is before you can fix it.

    Harley
     
  5. mightywhitey_k5

    mightywhitey_k5 Registered Member

    Joined:
    Sep 3, 2004
    Posts:
    74
    Likes Received:
    0
    my injectors seem to be getting a signal. I find it hard to believe that the injectors would go bad, i just replaced them recently. My truck died when i was out whellin; I came off a rock and banged my bumper on the rock prety hard after that my car was just dead. now i don't know WTF. I have gone throughand checked all the lines, the lines are fine i replaced the fuel filter; dark gas dumped out of the outlet side of it and i have replaced the Distrubitor control mod. all the fuses are good to go and the plugs spark perfictly. so what now? rember that when i came off a rock and hit my bumper on it my car died instantly.
     
  6. Hossbaby50

    Hossbaby50 3/4 ton status

    Joined:
    Sep 1, 2001
    Posts:
    8,972
    Likes Received:
    0
    Location:
    Peoria, AZ
    Not to be a dick but did you actually check to make sure your injectors are getting signal with the NOID light?

    If you pop in a Noid light and crank the key you will see 100% yes or no if the injectors are firing. If the noid light doesn't blink then you are not getting pulse, and if it does blink then you are getting pulse.

    If you are getting pulse and the injectors aren't firing and fuel then I would say the problem is in the TB somewhere since you said that fuel is getting to the TB.

    I am not sure what else to check beyond that. Someone else might be able to help you out beyond that or you may ask over at www.thridgen.org They know quite a bit about FI systems.

    Harley
     
  7. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    yeah you need ot know for sure that youre getting signal to injectors or not, you will see flash pulses


    TBI is a PITA when it gets old and starts developing problems, is usually never ending troubles past that point, component failures, wiring degradation, etc.

    tbi fires from signal from distributor i know,

    once i ran into problem with pink wire from coil over to distributor, it was busted inside insulation right near coil plug, wiggled it and would make injector spray fuel during crank, so got new wires from chevy for 20 bucks, white and pink ones,

    but it could be anything in your case, anything from temp sensor to wires, to coil to who knows.
     
  8. mightywhitey_k5

    mightywhitey_k5 Registered Member

    Joined:
    Sep 3, 2004
    Posts:
    74
    Likes Received:
    0
    Ya sorry guys i said that my injectors seem to be getting a signal what i ment was that they are getting a signal and still no spit from injectors. I dont know what would have gotten bumped loose in the tb but ill pull it and check it. this is my last hope.
     
  9. mightywhitey_k5

    mightywhitey_k5 Registered Member

    Joined:
    Sep 3, 2004
    Posts:
    74
    Likes Received:
    0
    no more thoughts i take it ok well thanks any way.
     
  10. dirtwarrior17

    dirtwarrior17 Banned

    Joined:
    May 14, 2004
    Posts:
    1,820
    Likes Received:
    0
    Location:
    Redding, CA
    I don't know jack about this but when i took off my old tb the lines had buildup in em right at the end of the fitting and probably got to the injectors. I had to clean em out with an ice pick. Is it dry or does a little fuel squirt out? Maybe clogged injectors?:confused: :dunno:
     
  11. sweetk30

    sweetk30 professional hooker Premium Member

    Joined:
    Nov 1, 2004
    Posts:
    25,526
    Likes Received:
    526
    Location:
    horseheads , ny 14845
    i think you said you got dark fuel out of lines . if so flush the system and try with a good known set of injectors. the crap might of pluged them.
     

Share This Page