Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

no power steering

Discussion in 'The Garage' started by Clod_King, Dec 27, 2005.

  1. Clod_King

    Clod_King 1/2 ton status

    Joined:
    Jun 7, 2005
    Posts:
    1,094
    Likes Received:
    0
    Location:
    Grimsby Ontario
    okay guys, my power steering is going caputz. the tires will turn perfectly fine as long as I am rolling (forwards or backwards). but when I stand still it makes a little squealing sound and refuses to turn the wheels. i do have a sweet smell coming from the truck when ever I leave it. I don't know if that is a the heater core, or power steering fluid. I know the smell is not coming from the radiator, because I replaced the rad, the hoses, the clamps, and a few fittings as well. I need the steering fixed for sure, would that be the pump? or the steering box? and when I do this should i put that steering bracket from ORD on there too?
     
  2. dave_90_blazer

    dave_90_blazer 1/2 ton status

    Joined:
    Jan 1, 2004
    Posts:
    688
    Likes Received:
    0
    Location:
    Melvindale, Michigan
    sounds like the belt is slipping, is the water pump leaking onto the belt?
     
  3. Clod_King

    Clod_King 1/2 ton status

    Joined:
    Jun 7, 2005
    Posts:
    1,094
    Likes Received:
    0
    Location:
    Grimsby Ontario
    it started after I went through a mud pit......
     
  4. Leper

    Leper 1/2 ton status

    Joined:
    Feb 18, 2005
    Posts:
    4,437
    Likes Received:
    0
    Location:
    Dallas Baby!!!!
    Your belt is slipping. Just replace it.
     

Share This Page