Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

no power to fuel pump

Discussion in 'The Garage' started by fright89, Mar 1, 2003.

  1. fright89

    fright89 1/2 ton status

    Joined:
    Sep 27, 2001
    Posts:
    279
    Likes Received:
    0
    Location:
    boston
    89 with tbi

    This little problem seemed to come on slowly. First it would not start if I had just shut it off. I would have to let it sit for a few minutes and it would start ok. My fuel pump is a Mallory 4060fi and I can here it when it runs, it is very loud. When it works right it runs for about 10 seconds when you shut off the truck. I think this sucks all the fuel back or something, not sure. This stopped and I think it would flood out a little when I shut it off so it would not start back up if I tried it right away. Then it just died while idling in my driveway, but started fine in a few minuets. Now it just won’t start

    The pump is ok I ran 12v over to it and it came to life with its normal happy whirling sound.

    I have replaced my fuel pump relay and redone some grounds.

    Are there any other modules or relays or stupid stuff like that I could try before I start chancing my wiring harness?
     
  2. dheavychevy38

    dheavychevy38 1/2 ton status Premium Member

    Joined:
    Jan 6, 2003
    Posts:
    1,003
    Likes Received:
    1
    Location:
    Algonquin,illinois
    check the oil preasure switch if it is bad it shuts off power to the fuel pump. did you check the fuse and how about the wiring
     

Share This Page