Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

no spark need help

Discussion in 'The Garage' started by pornorob, Apr 26, 2005.

  1. pornorob

    pornorob 1/2 ton status

    Joined:
    Jul 12, 2001
    Posts:
    215
    Likes Received:
    0
    Location:
    ;jkl;
    SO my truck died the other day ( 86 K5 , 350/sm465/208). Burnt up a fusable link and lost all power to the accessories. I fixed the wire but the truck still wont start. I have power going into the hei ( through the big pink wire) but I am getting no spark. Whats the deal?
     
  2. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,540
    Likes Received:
    930
    Location:
    Massachussetts
    might be the module..

    Sometimes the module will fry when a major short occurs--if your getting power to the pink wire,(and I assume you fixed the fuse links!)--then something like the module,pickup coil,or ignition coil got damaged--the most sensitive thing is the module,if your going to just throw parts in and see what fixes it,thats what I'd put in first...hope you dont have a computer,it can be damaged during a short too....if your truck has one,check the fuses,might have popped the ECM fuse,or another one that affects the ignition--check fuses first!... :crazy:
     

Share This Page