Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

No spark on a 88 with TBI. Help!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by great scott, Sep 6, 2003.

  1. great scott

    great scott 1/2 ton status

    Joined:
    Dec 31, 2002
    Posts:
    333
    Likes Received:
    0
    Location:
    Utah
    I am helping a freind out with a no start/ no spark problem on a 88 Blazer with TBI and external coil HEI. He has injector paulse, dist rotation, and key on power to the pink wire at the coil, but no spark. We have changed the modgual 3 times, the pick up twice, and ing coil once. With the tach disconected and a test light hooked in place we have key on power, but when I crank the engine over the test light dose not paulse. Any ideas would help.
     
  2. MTBLAZER89

    MTBLAZER89 3/4 ton status Premium Member GMOTM Winner

    Joined:
    Aug 14, 2001
    Posts:
    7,272
    Likes Received:
    237
    Location:
    Oak Harbor, WA
    Bad coil wire???
     
  3. great scott

    great scott 1/2 ton status

    Joined:
    Dec 31, 2002
    Posts:
    333
    Likes Received:
    0
    Location:
    Utah
    good idea but we checked allready and just to be safe we are useing 12 gauge wire tied to the coil tower to test spark. /forums/images/graemlins/1zhelp.gif
     
  4. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,060
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    No spark on a GM vehicle is usually one of two things, either the ignition module or pick-up coil inside the distributor.
     
  5. great scott

    great scott 1/2 ton status

    Joined:
    Dec 31, 2002
    Posts:
    333
    Likes Received:
    0
    Location:
    Utah
    I agree thats why we have changed them both at least twice thinking we must have gotten bad parts.
     
  6. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,060
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    Do you have spark at the coil? If you have spark at the coil but not the plug wires then I would suspect a burnt through rotor allowing it to ground out.
     
  7. great scott

    great scott 1/2 ton status

    Joined:
    Dec 31, 2002
    Posts:
    333
    Likes Received:
    0
    Location:
    Utah
    nop we have no spark at the coil.
     
  8. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,060
    Likes Received:
    69
    Location:
    Pleasanton, CA.
    No spark at the coil and since you have already replaced the coil I would say ignition switch is next.
     
  9. great scott

    great scott 1/2 ton status

    Joined:
    Dec 31, 2002
    Posts:
    333
    Likes Received:
    0
    Location:
    Utah
    I have power coming from the ing switch on the pink wire on the coil, so I belive the ing switch to be good.
     

Share This Page