Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

No Spark?

Discussion in 'The Garage' started by k5floyd, Jan 2, 2005.

  1. k5floyd

    k5floyd 1/2 ton status

    Joined:
    Feb 6, 2004
    Posts:
    313
    Likes Received:
    0
    Location:
    Friendswood, Tx
    just did a bit of beach wheelin' and i was crawling through a bigish hole(water just over the tires) the engine died. crawled throuh it cus i was having problems with the motor not wanting to stay alive after driving quickly through small holes, and water filled ruts. anyway, it didnt suck water into the intake, and the distributor was dry. i pulled the cap, and spayed a bit of wd40 in it, checked all of the terminals, checked battery posts, any wiring, fuses, and whatever else came to mind. then i pulled a spark plug, and no spark. any ideas??? all new ignition stuff, except, im still using the original coil. bad coil maybe? if its the coil, why would it decide to go out while i was in the water? and what about the motor not wanting to stay alive after the other water holes, and ruts? really need some help, but i guess thats nothing new...
     
  2. ryoken

    ryoken Puppy Fabricator Premium Member GMOTM Winner

    Joined:
    Jun 13, 2003
    Posts:
    29,621
    Likes Received:
    1,371
    Location:
    Jersey Shore
    ignition module would be my guess...
     
  3. k5floyd

    k5floyd 1/2 ton status

    Joined:
    Feb 6, 2004
    Posts:
    313
    Likes Received:
    0
    Location:
    Friendswood, Tx
    just wet or what?

    sorry, but i need some more help, as i have to go back to the beach and fix it in the morning.
     
    Last edited: Jan 2, 2005
  4. k5floyd

    k5floyd 1/2 ton status

    Joined:
    Feb 6, 2004
    Posts:
    313
    Likes Received:
    0
    Location:
    Friendswood, Tx
    nobody? come one guys, i need help quick. my truck is still down at the beach, 45 min from here, and i have to go fix it in the morning.
     
  5. ryoken

    ryoken Puppy Fabricator Premium Member GMOTM Winner

    Joined:
    Jun 13, 2003
    Posts:
    29,621
    Likes Received:
    1,371
    Location:
    Jersey Shore
    got sidetracked... :blush:

    those symptoms sound like a module freaking out to me.. maybe a hairline crack in it... pretty sure you can get em tested at the parts stores..

    did it get better or worse when hot before it crapped out?
     
  6. k5floyd

    k5floyd 1/2 ton status

    Joined:
    Feb 6, 2004
    Posts:
    313
    Likes Received:
    0
    Location:
    Friendswood, Tx
    what do you mean by "hot"? like drying out/warming up? before it crapped out, if in fact it is the ignition module, i would go through some water, and the motor would barely stay alive for a few seconds, and then die. start it back up, it would do the same thing. couple more tries and itd be fine, like nothing ever happened. so instead of getting any speed before entering the water, i would just crawl tough it, and no problems. that is untill the big hole. so i think something with the ignition is getting wet. ive got the msd 6a mounted near the top of my inner fenderwell, but that was going to be temporary untill i got around to making some longer wires, and putting it in the cab. i thought they were supposed to be sealed though? but maybe its got a crack in it somewhere like you said
     
  7. Cricket

    Cricket 3/4 ton status

    Joined:
    Nov 29, 2004
    Posts:
    8,224
    Likes Received:
    0
    Location:
    Colorado
    Hey Rich.

    If you haven't already you may want to go to msdignitions.com and have a look. Click on TECH SUPPORT, click on TROUBLE SHOOTING, click on CHECKING FOR SPARK. There is a small amount of information that may help or give you some ideas.

    You may want to just look everything over carefully in the morning. Make sure your mounts are tight and dry. No loose wires, good ground.

    The only real limitation I can find on mounting is not mounting it upside down. Sorry I couldn't be of more help.

    Good luck, Jim.

    If I lived close by I'd be happy to help you get it out. Maybe someone on this forum is near you and can help out. You never know.

    Good luck!
     
  8. k5floyd

    k5floyd 1/2 ton status

    Joined:
    Feb 6, 2004
    Posts:
    313
    Likes Received:
    0
    Location:
    Friendswood, Tx

Share This Page