Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

No spark

Discussion in 'The Garage' started by Blazer1AB, Sep 2, 2005.

  1. Blazer1AB

    Blazer1AB Registered Member

    Joined:
    Sep 1, 2005
    Posts:
    29
    Likes Received:
    0
    Location:
    KC
    My buddy's blazer wouldn't start the other day. Wasn't getting spark. He said he took off the coils and took them to a parts store and had them tested and they were fine. So he replaced the whole distributor and still nothing. He is gonna try a cap tomorrow and if that doesn't work does anyone have any suggestions? Ignition module maybe? Thanks for any help.
     
  2. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    The module is the first thing I would have checked. It certainly has the highest failure rate.
     
  3. Blazer1AB

    Blazer1AB Registered Member

    Joined:
    Sep 1, 2005
    Posts:
    29
    Likes Received:
    0
    Location:
    KC
    He was gonna replace the distributor anyways, thats why he wasn't really hesitant in buying it.
     
  4. Blazer1AB

    Blazer1AB Registered Member

    Joined:
    Sep 1, 2005
    Posts:
    29
    Likes Received:
    0
    Location:
    KC
    BTW, where is the ignition module on an 83 K5?
     

Share This Page