Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

No Spark !!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by opfor2, Aug 3, 2003.

  1. opfor2

    opfor2 1/2 ton status

    Joined:
    Oct 28, 2002
    Posts:
    375
    Likes Received:
    0
    Location:
    Ventura County, CA
    ****UPDATED**** No Spark !!!


    Hi All,

    I’m having a no run problem with my 1990 Chevy Blazer, 350 automatic w/ throttle body injection. The truck started up for about three seconds and when I put it into drive it died. I checked all of the fuses and they all appear to be ok, there is no code stored in the ECM.

    I disconnected the fuel line from the throttle body and turned the key on and guess what, We have a strong stream of fuel so that would eliminate the fuel pump.

    After doing some more trouble shooting I determined that I'm not getting a spark so I guess it's the ignition. I.ve heared that the ignition modules are cheap and fail alot on the Blazer is this true ? How do I test the module.



    Thanks

    Dan...
     
  2. Confedneck

    Confedneck 3/4 ton status

    Joined:
    Nov 1, 2002
    Posts:
    5,236
    Likes Received:
    0
    Location:
    Lehigh Acres, Florida
    Re: Fuel delivery problem

    just because you had fuel at that moment doesnt mean you do now...id try bleeding it out a couple incase it ingested some air into the lines...will it start if you pour fuel down the TB??
     
  3. fortcollinsram

    fortcollinsram 1/2 ton status

    Joined:
    Nov 8, 2001
    Posts:
    2,261
    Likes Received:
    0
    Location:
    Fort Collins, CO
    Re: Fuel delivery problem

    Replace the fuel filter, pull the injectors and check the filters on the injectors...and check Fuel pressure!!!Just because you have fuel volume doesn't mean you have enough fuel pressure.Make sure the ECM's signal is reaching the injectors...Maybe try another FP relay...
     
  4. JP's K5

    JP's K5 Registered Member

    Joined:
    Mar 19, 2002
    Posts:
    38
    Likes Received:
    0
    Location:
    Northern Nevada
    Re: Fuel delivery problem

    I know it may sound stupid but did you check the fuses. I had the same problem with a simple cure!
     
  5. opfor2

    opfor2 1/2 ton status

    Joined:
    Oct 28, 2002
    Posts:
    375
    Likes Received:
    0
    Location:
    Ventura County, CA
    Re: Fuel delivery problem

    ************REPAIRED********************


    It turned out that the ignition Mod was bad. $ 29.00 later and the truck is running better than ever.

    Thanks to all those who helped.


    Dan..
     
  6. 75-K5

    75-K5 3/4 ton status

    Joined:
    Apr 28, 2002
    Posts:
    5,353
    Likes Received:
    0
    Location:
    Anderson, Indiana
    Re: Fuel delivery problem

    I've got the same problem with an '83 Century I'm tinkering with. Maybe I'll give that a try! /forums/images/graemlins/thumb.gif
     
  7. KRAZIE87K5

    KRAZIE87K5 1/2 ton status

    Joined:
    Feb 23, 2001
    Posts:
    3,369
    Likes Received:
    0
    Location:
    Chicago, IL
    Re: Fuel delivery problem

    Some quick notes... code 42 is usually triggered with a bad ign. module. Also, AutoZone will test your module for free! ;-)

    -Dan
     

Share This Page