Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Noise in front end...Need Help

Discussion in 'The Garage' started by goblazeinco, Jul 14, 2004.

  1. goblazeinco

    goblazeinco Registered Member

    Joined:
    Nov 9, 2001
    Posts:
    33
    Likes Received:
    0
    Location:
    Longmont,CO
    I have a loud clicking coming from the front drivers side of my Dana44. It makes noise in relationship to the wheel spin, and stops when I apply very little brake. Sometimes it doesn't make any noise at all. I replaced the bearings because they would be the most obvious choice, but the noise is still there. And of course it won't do it when the tires are off the ground...that would be too easy. The ball joints are only about 3000 miles old.

    I went camping at Big Elk Meadows near Estes Park on the 4th and nothing broke.. so that was nice. I am not dumb (at least when it comes to cars)..But I can't find this click.

    I just wanted to see if anyone ese has had a similar problem, or if anyone has any sugestions.

    Thanks /forums/images/graemlins/k5.gif /forums/images/graemlins/dunno.gif
     
  2. khotmer

    khotmer 1/2 ton status

    Joined:
    Oct 23, 2002
    Posts:
    228
    Likes Received:
    0
    Location:
    columbus, oh
    maybe your hubs?
     
  3. ugly_blazer

    ugly_blazer 1/2 ton status

    Joined:
    Apr 12, 2004
    Posts:
    1,214
    Likes Received:
    0
    I'm guessing that you have a part time t-case. Does it do it in both 2 and 4 wheel drive, only 2, only 4? Also, what type of wheels are you using?
     

Share This Page