Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Noisy Vibrating A/C Compressor!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by eclipse, Jul 16, 2006.

  1. eclipse

    eclipse 1/2 ton status

    Joined:
    Jan 1, 2005
    Posts:
    1,245
    Likes Received:
    0
    Location:
    Sparks, NV
    The A/C blows cold air in my 89 Suburban, but at an idle the A/C pump vibrates and it is very very noisy. I thought it was maybe the clutch cause I'm still getting cold air. So a friend had a rolled '95 s10 jimmy, I pulled that pump off and put it on my burb today... samething! Still cold air but I'm wondering if its something other than the pump, or I have bad luck and have two pumps that problems. Its only at an idle, I can put my foot on the gas barely and it goes away.

    I gotta get this A/C working right, I feel bad, we sold my wife's 01 Tacoma to get out of payments and get a bigger rig and bought her the burb...
     
  2. 4xcrazy

    4xcrazy 3/4 ton status

    Joined:
    Oct 31, 2003
    Posts:
    9,471
    Likes Received:
    5
    Location:
    Olympia/Lacey, Washington
    Mine did the same thing, not sure what it is, kinda like a growling noise, right?

    People used to ask what it was when i had the ac on,,oh well, at least i had cold air, when it was working anyways.:doah:
     
  3. eclipse

    eclipse 1/2 ton status

    Joined:
    Jan 1, 2005
    Posts:
    1,245
    Likes Received:
    0
    Location:
    Sparks, NV
    yeah its like a growling noise, and its loud as hell, and my burb is quite being bone stock.
     
  4. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    Do you have another truck that you can compare yours with? It sounds like there might be a support bracket missing. GM braced the A/C compressor from several different angles, but one or more of the brackets sometimes get left off during a repair. Just a single missing bracket can cause harmonic vibrations.

    Leaving off the bracket that goes from the back of the alternator to the intake can also cause the alternator to vibrate in a similar fashion.
     
  5. eclipse

    eclipse 1/2 ton status

    Joined:
    Jan 1, 2005
    Posts:
    1,245
    Likes Received:
    0
    Location:
    Sparks, NV
    I'll have to check. I was also told today it could be my idler puller worn out and that it only does it when a/c comp puts a load on it, I'm gonna check that out tonight and look for missing brackets
     
  6. eclipse

    eclipse 1/2 ton status

    Joined:
    Jan 1, 2005
    Posts:
    1,245
    Likes Received:
    0
    Location:
    Sparks, NV
    I figured it out... yay! the annoying vibe... its the aluminum backet that holds the A/C compressor and the idler pulley, its cracked and stripped out where the braces hold it. I noticed some cracks, so I fired up the rig and pushed on the pump and it went away. Back to the rolled 95 Jimmy for the backet... damn I didn't need to change the pump.
     
  7. 4xcrazy

    4xcrazy 3/4 ton status

    Joined:
    Oct 31, 2003
    Posts:
    9,471
    Likes Received:
    5
    Location:
    Olympia/Lacey, Washington
    Well, yours must have been a REALLY loud growl then, cause i know i don't have any broken brackets or missing rods, just a noisy compressor.:crazy:
     

Share This Page