Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Normal oil pressure for 6.2????

Discussion in '1982-Present GM Diesel' started by 6.2Blazer, Nov 16, 2001.

  1. 6.2Blazer

    6.2Blazer 1/2 ton status

    Joined:
    Feb 24, 2000
    Posts:
    4,675
    Likes Received:
    26
    Location:
    Ohio
    Okay, I've got a '90 K5 with the 6.2 with about 108,000 miles on the engine. What should the oil pressure be at idle and under load? I'm a little concerned because it seems a little low. Also, what would typically cause low oil pressure in 6.2. I don't drive the truck that much because it's pretty much a dedicated trail rig.
     
  2. Can Can

    Can Can Pusher Man Staff Member Super Moderator

    Joined:
    Feb 17, 2000
    Posts:
    15,552
    Likes Received:
    136
    Location:
    Cochrane, Alberta, Canada
    My oil gauge records KPAs not PSI, but cold at high idle and while driving mine reads somewhere between 2/3 and 7/8 of the way up the guage. The lowest it gets is at idle while towing on a hot summer day, but even then it only drops a shade below half.

    Have you checked your oil pressure sending unit?



    <font color=blue> NEVER FORGET, NEVER FORGIVE, NEVER SURRENDER<font color=blue>
     
  3. DieselDan

    DieselDan 1/2 ton status

    Joined:
    Jan 27, 2001
    Posts:
    1,056
    Likes Received:
    0
    Location:
    Vermont
    My personal Jimmy runs about 45 psi at part throttle, maybe as low as 30 at hot idle. I gotta check a HMMWV tomorrow thats running about 15 psi at part throttle and as low as 5 psi at hot idle. Mechanically it does "sound" any different, so maybe it's a bad guage/sender.

    Real trucks don't have spark plugs!
     
  4. JORGE

    JORGE 1/2 ton status

    Joined:
    Jan 10, 2001
    Posts:
    213
    Likes Received:
    0
    Location:
    VITORIA-GAZTEIZ(ALAVA)BASQUE COUNTRY,SPAIN
    The original Ac delco gauge senders are notorious for going bad.Mine doesn,t pass to 20 psi and the sender is new.I,ve tested the oil pressure with a good mechanical gauge and it is very good.I,m going to install a mechanical isspro gauge in the place of the original gauge.
     
  5. 6.2Blazer

    6.2Blazer 1/2 ton status

    Joined:
    Feb 24, 2000
    Posts:
    4,675
    Likes Received:
    26
    Location:
    Ohio
    Mine is reading a little under the 40 (maybe 35 or so) mark on the stock guage when hot and with any throttle at all (it doesn't matter if you are just barely touching the throttle or flooring it....), and around 15-20 at idle. The thing that makes me question the factory guage is that it doesn't change hardly at all between a cold startup and once it's hot.

    I will see if I can get is setup with a mechanically guage to double check. Where is an easy place to hook a guage up to check the pressure?
     

Share This Page