Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

occasionally smoking?....pinging?...running crappy? ... auto? READ THIS !!

Discussion in 'The Garage' started by uglychevyZZ4, Mar 20, 2004.

  1. uglychevyZZ4

    uglychevyZZ4 3/4 ton status

    Joined:
    Apr 26, 2002
    Posts:
    6,094
    Likes Received:
    0
    Location:
    Black Diamond, Wa
    read this if you have

    ok, heres the scoop. we lost our last motor when it suddenly started smoking badly, figured ok, its toast & bought a new zz4. soon it started this thing where it would die, or miss so we startd going through ignition stuff, everything was soon replaced, nothing changed, for very long. then it progressed to suddenly start pinging and smoke very badly, so we replaced sensors and nothing. gave up took ito to a shop finally and they said it was the ecm and injectors, so guess what CHA-CHINGGGG /forums/images/graemlins/rolleyes.gif NOTHING /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif /forums/images/graemlins/angryfire.gif

    11 months later now we had given up, and began to thing it was thre new engine since the smoke was BLUE like oil, but i wasnt convinced yet since it only smoked when it pinged, so i started calling to get in to yet...another shop and a guy over the phone asked me to walk to my truck while on the phone, i did, and he asked me to check my oil, and he was right on the money it was 2 qts overfull..... /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif ok, then he says to yank my tranny modulator vacume line off, so i did, and "yes sir, tranny fluid is coming out" I says..

    BINGO it was junk, the vacume pod is ripped internally and allowing me to suck tranny fluid from my pan into my intake /forums/images/graemlins/hack.gif intermittenly and smoke and also foul the plug closest to the vacume inlrt, the 2 rear passenger ones. so, after a new engine, 1400$$ worth of diagnostics and a for sale sign the fix was a $ 14.00 part and a oil change.. /forums/images/graemlins/woot.gif /forums/images/graemlins/woot.gif /forums/images/graemlins/woot.gifwow, this thing hauls ass now /forums/images/graemlins/woot.gif /forums/images/graemlins/woot.gif
    Rob
     
  2. bigyellowjimmy

    bigyellowjimmy 1/2 ton status

    Joined:
    Jan 15, 2004
    Posts:
    2,105
    Likes Received:
    0
    Location:
    Chandler, AZ
    Very interesting! Congrats on a succesful fix /forums/images/graemlins/thumb.gif
     
  3. SUBFAN

    SUBFAN 1/2 ton status

    Joined:
    Mar 23, 2003
    Posts:
    2,334
    Likes Received:
    0
    Location:
    Davenport, Ia
    Sometimes, it is the little things that will get you....

    Glad it is running fine now. Makes you wonder if the last motor was really bad /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif /forums/images/graemlins/doah.gif
     
  4. jakeslim

    jakeslim 1/2 ton status

    Joined:
    Sep 18, 2002
    Posts:
    2,686
    Likes Received:
    0
    Location:
    Napa, CA
    I just went through this. Thought it was a head...luckily I caught a post mentioning it, but not before i changed the intake gasket. It was the module.
     
  5. uglychevyZZ4

    uglychevyZZ4 3/4 ton status

    Joined:
    Apr 26, 2002
    Posts:
    6,094
    Likes Received:
    0
    Location:
    Black Diamond, Wa
    [ QUOTE ]
    Makes you wonder if the last motor was really bad /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif /forums/images/graemlins/doah.gif

    [/ QUOTE ]it was good, until it saw too much tranny fluid, ya the valve guide seals got descintagrated
    /forums/images/graemlins/whistling.gif
     
  6. 84gmcjimmy

    84gmcjimmy 1 ton status

    Joined:
    Dec 3, 2003
    Posts:
    12,838
    Likes Received:
    0
    Location:
    B.C. CANADA
    Woah that sucks, at least its fixed and running now! /forums/images/graemlins/waytogo.gif
     
  7. Stomper

    Stomper ΜΟΛΩΝ ΛΑΒΕ GMOTM Winner

    Joined:
    May 11, 2002
    Posts:
    3,767
    Likes Received:
    0
    Location:
    Iowa
    You better go buy that guy on the phone a round /forums/images/graemlins/waytogo.gif /forums/images/graemlins/peace.gif
     
  8. uglychevyZZ4

    uglychevyZZ4 3/4 ton status

    Joined:
    Apr 26, 2002
    Posts:
    6,094
    Likes Received:
    0
    Location:
    Black Diamond, Wa
    we did, a case.. /forums/images/graemlins/waytogo.gif
     
  9. thezentree

    thezentree 3/4 ton status

    Joined:
    Sep 19, 2003
    Posts:
    7,198
    Likes Received:
    0
    Location:
    NC
    sounds like my truck... /forums/images/graemlins/thinking.gif except without the smoking part... /forums/images/graemlins/dunno.gif
     
  10. jjlaughner

    jjlaughner 3/4 ton status

    Joined:
    Jan 12, 2001
    Posts:
    7,406
    Likes Received:
    0
    Location:
    Indiana
    When I had my 83 dodge pickup it never ran right and it smoked. So I yanked the heads off sent them out to be milled magnafluxed 3angle valve grind, seals whole thing. Checked the cylinder walls and rings everything looked good. Reassembled still had problems, replaced the coil, and wires (it had a new cap rotor and plugs). NOthing still ran the same... crappy!

    Finally took it to the electrical guys and had them give the once over, he calls me about 3 hours later says its fixed /forums/images/graemlins/yikes.gif (I was a little worried because I didn't OK any fixes)... so I ask WHAT WAS WRONG? Crack in the distributor cap /forums/images/graemlins/blush.gif /forums/images/graemlins/crazy.gif /forums/images/graemlins/doah.gif

    $300 worth of stuff and 2months work and its was a $17 part that I had already replaced /forums/images/graemlins/doah.gif
     

Share This Page