Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Odd Engine troubles?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by nau81blazer, Jun 8, 2005.

  1. nau81blazer

    nau81blazer 1/2 ton status

    Joined:
    Mar 6, 2004
    Posts:
    329
    Likes Received:
    0
    Location:
    Cincinnati, OH
    Hello all,

    So I was driving blazer yesterday and about 5 minutes after I started it, it started to slightly miss, and then a little worse, and then it was running pretty bad, then it was barely running. Real dark black smoke, it will start but i have to stay on the gas a bit the whole time and it still misses really bad. Odd thing is it gradually happened within 15 minutes. Anyone heard of this? I check the distributor hold down to see if it was loose and the dist. was moving around. It was tight down though. I assume a carb. problem cause of the black smoke. Any ideas of where to keep looking would be greatly appreciated. Thanks for the help guys! :D

    --Adam
     
  2. 4X4HIGH

    4X4HIGH 1 ton status Premium Member GMOTM Winner

    Joined:
    Dec 14, 2001
    Posts:
    22,063
    Likes Received:
    71
    Location:
    Pleasanton, CA.
    Black smoke means too rich, check for a bad choke. The choke plate should be wide open when the engine is warmed up to operating temps.
     
  3. kd7kmp

    kd7kmp Registered Member

    Joined:
    Jun 2, 2004
    Posts:
    99
    Likes Received:
    0
    Location:
    Springivlle, Utah
    It sounds like 4X4HIGH is right on. Your choke may be stuck closed.

    Kevin
     
  4. nau81blazer

    nau81blazer 1/2 ton status

    Joined:
    Mar 6, 2004
    Posts:
    329
    Likes Received:
    0
    Location:
    Cincinnati, OH
    Cool, thanks guys! :thumb:

    --Adam
     

Share This Page