Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Oil gauge pegged at 60+

Discussion in 'The Garage' started by scoutillac, Apr 28, 2004.

  1. scoutillac

    scoutillac 1/2 ton status

    Joined:
    Feb 24, 2004
    Posts:
    423
    Likes Received:
    0
    Location:
    Spokane, Wa.
    As you all probably know the burb sucked H2O and is smoking like hell. So I ordered up some parts for the rebuild. Someone told me because the air filter was wet it created an extreme amount of vacuum and sucked a valve. But now the oil pressure guage is throwing a fit. Does anyone know why all of a sudden my oil gauge is pegged out above 60 when the rig is on or off?
     
  2. unclematty

    unclematty 1/2 ton status

    Joined:
    Jan 24, 2003
    Posts:
    3,164
    Likes Received:
    0
    Location:
    SLC UT
    never seen that before. try removing the sender and cleaning it /forums/images/graemlins/dunno.giflet us hear what you find
     
  3. yunit

    yunit 1/2 ton status

    Joined:
    Feb 24, 2000
    Posts:
    3,068
    Likes Received:
    0
    Location:
    Oakland, NJ
    Make sure that the wire going to the sensor is connected.
     
  4. Wingnutt

    Wingnutt 1/2 ton status

    Joined:
    Feb 20, 2000
    Posts:
    324
    Likes Received:
    0
    Location:
    NOVA
    Mind did that just last week. Replaced the sending unit and life was good again.
     
  5. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    if the wire grounds out, IE melts ot exhaust manifold then it will peg the needle, search for and follow the singel dark green wire on driver side cylinder head in between the first and second cylinders, have someone watch the needle with igniton key on while you trace and move wire around,


    none of this has anything to do with it having been burning water
     
  6. scoutillac

    scoutillac 1/2 ton status

    Joined:
    Feb 24, 2004
    Posts:
    423
    Likes Received:
    0
    Location:
    Spokane, Wa.
    I'll look there tomorrow. /forums/images/graemlins/waytogo.gif
     
  7. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    Dang, I feel bad that our water hole caused all this hassle and damage. /forums/images/graemlins/blush.gif
     
  8. stallion85

    stallion85 1/2 ton status

    Joined:
    Jul 11, 2003
    Posts:
    3,659
    Likes Received:
    0
    Location:
    Cedar City, UT
    [ QUOTE ]
    As you all probably know the burb sucked H2O and is smoking like hell. So I ordered up some parts for the rebuild. Someone told me because the air filter was wet it created an extreme amount of vacuum and sucked a valve. But now the oil pressure guage is throwing a fit. Does anyone know why all of a sudden my oil gauge is pegged out above 60 when the rig is on or off?

    [/ QUOTE ]

    Do you mean it reads 60 at all times? Mine always reads like that /forums/images/graemlins/thinking.gif Is that not normal? I thought it was /forums/images/graemlins/thinking.gif
     

Share This Page