Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

oil pressure check

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by olbluebeast, Jun 15, 2001.

  1. olbluebeast

    olbluebeast Registered Member

    Joined:
    Mar 16, 2001
    Posts:
    16
    Likes Received:
    0
    Location:
    austin,tx
    my oil pressure guage says between 0 and 15 lbs of pressure and does not move much between firing it up and running rpms. the oil is full, the truck seems to run fine and does not clatter or overheat. what is the deal ? whAT SHOULD I CHECK? IS THE OIL PUMP PUMPING, IS THE GAUGE SHOT, OR DO I NEED TO REPLACE THE SENSOR FOR THE GAUGE, AND IF SO WHERE IS IT?
     
  2. maxq15

    maxq15 Registered Member

    Joined:
    May 16, 2001
    Posts:
    44
    Likes Received:
    0
    Location:
    Miami, Florida
    Well, I can probably get you started in the right direction. If you don't get the symptoms of truly low oil pressure than it would be relatively safe to assume that the indication is inaccurate. Most likely the sending unit. As for the specific location, that I'm not sure of. I had someone else replace mine when it was bad and wasn't there to see where it was. Sorry!

    Those who think money can't buy happiness don't know where to shop.
     
  3. 83ZZ502_Jimmy

    83ZZ502_Jimmy 1/2 ton status

    Joined:
    Feb 7, 2001
    Posts:
    3,103
    Likes Received:
    0
    Location:
    Richmond, VA
    Replace the sender, it is located (normally) behind the distributor. It looks like a bell. Normally gold in color. If that doesn't solve the problem, it could be in the wiring. The best thing to do is to take a mechanical gauge and hook it up TEMPORARILY!! This gauge does not lie. You will probably find your sender or gauge is bad.

    My .02
    Hope it helps,
    John

    '83 GMC Jimmy 4x4 ZZ4 Crate Motor
    '83 Chevy P/U 4x4 Sand Drag Racer, 578 RWHP
    '94 Impala SS
    '01 Chevy 2500HD w/8.1L & Allison Auto
     
  4. Itali83

    Itali83 1/2 ton status

    Joined:
    Feb 12, 2001
    Posts:
    795
    Likes Received:
    0
    Location:
    Westbrook Maine
    the sending unit is not the one behind the distributor. That is the low oil pressure shut off sender. The oil pressure guage sender is right on top of the oil filter. It does look like a bell and you can't miss it. Change that and it should (hopefully) change the reading. Or if you really want accuracy, go mechanical for the guage.
    Ben 87 Jimmy
    <A target="_blank" HREF=http://www.bens87toy.coloradok5.com>http://www.bens87toy.coloradok5.com</A>
     

Share This Page