Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Oil pressure sender

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by JORGE, Jul 26, 2001.

  1. JORGE

    JORGE 1/2 ton status

    Joined:
    Jan 10, 2001
    Posts:
    213
    Likes Received:
    0
    Location:
    VITORIA-GAZTEIZ(ALAVA)BASQUE COUNTRY,SPAIN
    Somebody has been having troubles with the AcDelco oil pressure senders?I have put a new one in my 6.2 Diesel and the pointer doesn,t pass to 20 psi. I,ve heard this units are very bads....
     
  2. HarryH3

    HarryH3 1 ton status Author

    Joined:
    May 31, 2000
    Posts:
    10,384
    Likes Received:
    2
    Location:
    Georgetown, TX
    Jorge, you may want to try a mechanical oil pressure gauge that you know works right, just to make sure. Perhaps your oil pressure really is just 20 psi. [​IMG]

    <font color=black>HarryH3 - '75 K5</font color=black>
    <a target="_blank" href=http://www.angelfire.com/super/ThunderTruck>www.angelfire.com/super/ThunderTruck</a>
    It's a great day to be alive...
     
  3. dyeager535

    dyeager535 1 ton status Premium Member

    Joined:
    Dec 13, 2000
    Posts:
    26,975
    Likes Received:
    189
    Location:
    Roy WA
    Gotta make sure that they are giving you the right sender as well...there are 60 psi and 80psi ones, yours is 80psi. the senders are internally different, and will work, but will give incorrect readings.


    Dorian
    My tech/links page: <a target="_blank" href=http://www.dorianyeager.com/index2.html>http://www.dorianyeager.com/index2.html</a>
    No anti-theft measures on your truck? No pity when its stolen
     

Share This Page