Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

OK let me try this agian i need help

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by pplblazerdude, Jan 1, 2003.

  1. pplblazerdude

    pplblazerdude 1/2 ton status

    Joined:
    Jul 18, 2002
    Posts:
    242
    Likes Received:
    0
    Location:
    Kingsport, Tennessee
    I have a 88 full size blazer equiped with throttle body injection and recently i installed a throttle body spacer and sence i have installed the spacer the truck has idled higer and the brakes arent as good as before is there anyway i can fix this so i can us the spacer and have every thing back to normal cause it really made a noticable diffrence. Thanks


    /forums/images/graemlins/k5.gif
     
  2. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    maybe check all your vacuum hoses (just a shot in the dark) to make sure by lifting the throttle body you didnt pull one loose or stretch it or something.
     
  3. pplblazerdude

    pplblazerdude 1/2 ton status

    Joined:
    Jul 18, 2002
    Posts:
    242
    Likes Received:
    0
    Location:
    Kingsport, Tennessee
    Ill do that thanks for the advice.
     
  4. Bubba Ray Boudreaux

    Bubba Ray Boudreaux 1 ton status

    Joined:
    Jan 21, 2001
    Posts:
    20,716
    Likes Received:
    2
    Location:
    Undisclosed Location
    If it's not vacuum lines, also make sure the gaskets are all good. If the TBI is sucking in more air than it should, the computer will add more fuel.
     
  5. Sandman

    Sandman 3/4 ton status Author

    Joined:
    Apr 15, 2002
    Posts:
    5,653
    Likes Received:
    0
    Location:
    Pocatello, ID
    Try looking here:

    Here
     
  6. Michael

    Michael 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,576
    Likes Received:
    0
    Location:
    Sherman, Texas
    Try making your subject line more informative as to what your problem is....like "High idle after throttle body install???" It should help with responses. Also, you can always go back and edit anything in your post, that way you don't have to make the exact same post again. Good Luck!
     
  7. heavy4x4

    heavy4x4 1/2 ton status

    Joined:
    Aug 28, 2002
    Posts:
    3,270
    Likes Received:
    0
    Location:
    Delafield, Wisconsin
    You need to install the throttle bracket spacers too....did you do that?
    I've installed a tbi spacer on my truck, and I started it up after putting the tbi spacer on, and the idle was really high. So, I unbolted the throttle bracket (back right of intake manifold if looking at front of engine), where the throttle and tv (for transmission) cables are. Then, put the new-included-in-kit spacers under the bracket and installed the new intake bolts. Started it up...and it was back to the normal idle. When you install the spacer...you lift up the tbi unit (duh...talk about stating the obvious), but that in turn pulls on the throttle cable/linkage and opens the butterfly valves just enough to raise idle.
    The only other thing I had to do for this mod was adjust the tv cable....easy procedure...but I won't go through it now 'cuz I'm not sure if you have the 700r4.
    Hope this helps...oh yeah, and changing the subject line to something like, "tbi spacer problems" would get peoples attention (like mine) quicker.
     

Share This Page