Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

ok..need new ideas...

Discussion in 'The Garage' started by bryguy00b, Mar 16, 2003.

  1. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    well my turn signals arent working..and either is my backup light and horn..(i think they are all on the same fuse or what not type thing) but we checked the fuses..they are all good..what other reasons could there be for these not working? oh yea..my radio doesnt work either! i know nothing about electrical stuff..i also hate it..is there a place i could take a it to have this type of work done?
     
  2. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    Is it a PU or a blazer? I had an 81 PU with dual tanks with an electric switch and I had the same probs. Turned out it was the fuse for the tank switch.
     
  3. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
    really? now why the heck would that cuase it...cuase i to have dual tanks with the switch..and yea its a PU. i dont even think the switch wokrs..its broked of and kinda hangin there..and i only use the pass side tank. but what would the tank switch have to do with it? what should i do? how would i know if the switch works?
     
  4. bryguy00b

    bryguy00b 3/4 ton status

    Joined:
    Apr 7, 2002
    Posts:
    5,587
    Likes Received:
    0
    Location:
    Rochester, N.Y
  5. madmike

    madmike 1/2 ton status

    Joined:
    Jan 23, 2002
    Posts:
    496
    Likes Received:
    0
    Location:
    ohio
    Check all ground wires, especially the bed to frame ground wire, cab to engine block, and engine block to frame. I had a bad bed to frame ground wire, drove me nuts because my turn signals quit working properly. I checked everything, looked at fuses, had the dash apart (I had just reassembled the interior), and the problems I had all originated from a bad ground connection. Electrical problems are almost always an easy fix, just hard to find sometimes. Hope this helps!
     

Share This Page