Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Out of blinker fluiid???

Discussion in '1983-2005 S-Series models' started by 85 Shortbox, Nov 21, 2002.

  1. 85 Shortbox

    85 Shortbox 1/2 ton status

    Joined:
    Jan 24, 2002
    Posts:
    138
    Likes Received:
    0
    Location:
    Grandville, Mi
    My turn signals one day just quit working, I changed the blinker relay and it still does nothing. Oh yeah the hazard lights do work. It is a 92 S-10 4x4. Any ideas? Thanks guys.
     
  2. 89GMCSuburban

    89GMCSuburban 1/2 ton status

    Joined:
    Nov 15, 2001
    Posts:
    3,005
    Likes Received:
    0
    Location:
    Thornton, CO
    Check the bulbs in the front bumper...if burned out, the stupid things won't blink.
     
  3. Blaze

    Blaze 1/2 ton status

    Joined:
    Aug 28, 2000
    Posts:
    3,285
    Likes Received:
    0
    Location:
    Raleigh, NC
    Have you checked all your fuses?
     
  4. MEPR

    MEPR 1/2 ton status

    Joined:
    Oct 21, 2002
    Posts:
    1,546
    Likes Received:
    0
    Location:
    McChord AFB
    check your fuses and make shure the blinker you replaced was your trun signals and not your hazzard blinker (both are the same though)
     
  5. RootBreaker

    RootBreaker 3/4 ton status Premium Member

    Joined:
    Nov 29, 2001
    Posts:
    5,118
    Likes Received:
    173
    Location:
    Williamstown, NJ USA
    ohhh ohhh... what i was lookin for... i have a 1996 and cant figure out where the blinker is... my fuses are ok and my hazzards work. But i dont even have turn signal lights show up on the dash?!?!?!?!?!
     
  6. Confedneck

    Confedneck 3/4 ton status

    Joined:
    Nov 1, 2002
    Posts:
    5,236
    Likes Received:
    0
    Location:
    Lehigh Acres, Florida
    its the multifunction switch, pull the column trim off and look for loose wires at the back of the connector for the multifunction switch (what controls the wipers and turn signals...), if all the wires are ok.. check to see if all your brake lights work.. you can pm me if you need any info...
     

Share This Page