Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Pain In My @$$!!!

Discussion in 'The Garage' started by jmeti000, Jan 15, 2006.

  1. jmeti000

    jmeti000 Registered Member

    Joined:
    Jul 13, 2005
    Posts:
    33
    Likes Received:
    0
    Location:
    texas
    so i just got my oil changed the other day, and all of the sudden my truck starts acting up. heres the deal. starts out cold with 60 oil pressure and sounds great, then slowly drops to about 10 as i drive it. when i accelerate the pressure will go up, but then gradually fall..again. and there is a tapping noise i noticed today when i got off the freeway. was on my way home and it sounded horrible at the stoplight. after about 3 miles of 35-45 mph the tapping went away and didnt return, however the oil pressure had not moved from 10. i pulled over and popped the hood at one point and it sounds like its coming from the passenger side rocker covers. mind you the pressure has always done this, but the recent tapping sound is whats killing me. any ideas or experiences with this??
    thanks
    jac
     
  2. jeeptuff

    jeeptuff 1/2 ton status

    Joined:
    Aug 22, 2005
    Posts:
    158
    Likes Received:
    0
    Location:
    Arlington, WA
    Sounds like either a lifter that isn't staying "pumped up" or you need to adjust the valves, what kind of tapping is it sound wise???
     
  3. jmeti000

    jmeti000 Registered Member

    Joined:
    Jul 13, 2005
    Posts:
    33
    Likes Received:
    0
    Location:
    texas
    very rythmical....tapping. but does get faster when i accelerate. it sounds like one of the rockers is hitting the cover, but i would think if thats the case it would do it all the time, not just after freeway driving. it wont do it when its cold. i have only heard it after getting off of the freeway thus far, and like i said, it went away after about 3 miles and i couldnt get it to do it again to listen when i got home tonight. the engine has about 54k on it so i wouldnt think its going bad yet..unless they did a crappy job. am taking it back to put 20/50 in it tomarrow to see if that helps. i bought a oil pump today but im still not completely convinced that could be even part of the problem....could it??
    jac
     
  4. bobalob

    bobalob 1/2 ton status

    Joined:
    Jul 20, 2005
    Posts:
    157
    Likes Received:
    0
    Location:
    Everson, Washington
    I had very similar problem (oil psi/tapping) and when valve cover was removed you could see that a few of the lifters had tons of play and were barely coming up. In the end it turned out the pressure relief valve in the pump was sticking and the lack of oil psi resulted in wiped out cam lobes+lifters.
     
  5. Emmettology 101

    Emmettology 101 3/4 ton status

    Joined:
    May 9, 2000
    Posts:
    8,126
    Likes Received:
    0
    Location:
    FL
    Have you checked the oil level since you had the oil changed? Have seen some engines that they dont screw the drain plug back in all the way and it falls out or leaks. A low oil level will cause tapping! Or an improperly filled oil level...
     
  6. muscle

    muscle 1/2 ton status

    Joined:
    May 28, 2000
    Posts:
    408
    Likes Received:
    0
    Location:
    Show Low, AZ
    10psi is not good for oil pressure. your top end will suffer first from lack of pressure, especially hyraulic lifters. Doesnt do it as much cold because the oil is thicker and more viscous.

    hate to say it but get ready for disaster soon.
     
  7. jmeti000

    jmeti000 Registered Member

    Joined:
    Jul 13, 2005
    Posts:
    33
    Likes Received:
    0
    Location:
    texas
    alright, i just got back from the shop...i had my oil pressure sensor changed and put 20/50 in it. my oil pressure gauge works great now, says i run at about 30-45, and idol at about 15. and no more ticking. im guessin it didnt like the 10/30 very much after running for a bit...anyways, hope this helps someone a little. thanks all for your help, and till next time
    jac
     

Share This Page