Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Part throttle miss???

Discussion in 'The Garage' started by '73 K5, Jan 4, 2004.

  1. '73 K5

    '73 K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,763
    Likes Received:
    0
    Location:
    Kansas
    Maybe some of you guys would like to take a guess at why my Blazer is running like poop. Truck was running fine...took it on the highway and drove fast for about 10 miles and when I got off the highway, it had developed a part throttle miss, surging, bucking, etc. I was flowing along at around 85 which was around 3500 RPM or maybe a little higher. Then later, it ran fine for a few days, then I noticed the miss again. Some days it won't do it at all, and other days it'll run like crap. Seems to be getting worse as the days go on though. The thing runs great when I mat the pedal, so who knows. Any ideas?
     
  2. R72K5

    R72K5 Banned

    Joined:
    Mar 5, 2001
    Posts:
    8,905
    Likes Received:
    0
    Location:
    central IL
    tighten up all the carb screws and the mounting bolts and then with engine running rev engine up by hand at carb and slap choke shut on her while keeping throttle open and then let go of choke flap and let engine catch up again, should be fine then after that,
     
  3. Topdown

    Topdown 1/2 ton status

    Joined:
    Nov 26, 2002
    Posts:
    2,598
    Likes Received:
    0
    Location:
    Vancouver, Washington, U.S.A
    Out of curiosity, does it stumble, jerk, etc... when you push the pedal to about 2/3 but runs fine at 1/3 and WOT?

    any luck getting it figured out?
     

Share This Page