Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Perpetual Choke Light??

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Cavalry, Nov 8, 2000.

  1. Cavalry

    Cavalry 1/2 ton status

    Joined:
    Oct 1, 2000
    Posts:
    978
    Likes Received:
    0
    Location:
    upstate NY(although I cant figure out why)
    My choke light never goes out (ign on) in my '84. The choke operates fine and has 14 volts going to it. I'm sick of waiting for the bulb to burn out. Thanks Luke
     
  2. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,180
    Likes Received:
    1,388
    Location:
    E-town baby!
    I see my choke light come on once in a while too. Mines an 81 Jimmy. On mine I just turn the key a little farther and the light goes out. I just figured "whatever". If that doesn't work remove the bezel and remove the choke light.[​IMG]

    Rene

    [​IMG]
     
  3. RaisedK5

    RaisedK5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    932
    Likes Received:
    0
    Location:
    Long Beach, CA
    This may sound silly but check all the fuses, my sister has an '80 Camaro, and the oil light was always on, well after stareing at the wiring diag. for four hours i finally figured it out, a fuse blew, and the choke is wired through (0n that model) the oil pressure sensor, so there was a ground backfeed through the choke, through the sensor to the light, replaced the fuse and boom out it went, the choke worked, since it was getting power from the inst. panel but it worked better when i fixed the problem, Just a thought.

    RaisedK5

    "Friends don't let friends drive Fords"
     
  4. Scottsdale

    Scottsdale Registered Member

    Joined:
    Nov 6, 2000
    Posts:
    9
    Likes Received:
    0
    Location:
    South Carolina
    Mine won't go off either. It started after I put a set of mechanical gauges on. I just left the wiring for the old oil sensor tied to the frame. I'll check the fuse though.

    Bowties, hate wearin' em, love driven' em!
     
  5. jimmyjack

    jimmyjack 1/2 ton status

    Joined:
    May 11, 2000
    Posts:
    2,290
    Likes Received:
    0
    Location:
    Tucson Az
    I've heard its got something to do with your oil, whether its low pressure or low amount. Might be worth checking.

    creepin' and crawlin'

    Jim
     
  6. Cavalry

    Cavalry 1/2 ton status

    Joined:
    Oct 1, 2000
    Posts:
    978
    Likes Received:
    0
    Location:
    upstate NY(although I cant figure out why)
    Mine started doing this trick after having the carb off to rejet. Put it back on and the light never went off again. As far as pulling the bulb, I'm not going to make any special trips to pull the cluster, If noone can come up with a fix I'll wait till it burns out or pull the bulb next time I have the dash tore out.... Who the hell really needs a light to tell them the choke is on? What exactly is the purpose of it?
     

Share This Page