Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Pics of my beater 86 S10, 300K and counting fast

Discussion in '1983-2005 S-Series models' started by kennyw, May 30, 2003.

  1. kennyw

    kennyw N9PHW Premium Member

    Joined:
    Jun 9, 2002
    Posts:
    13,223
    Likes Received:
    94
    Location:
    Stevens Pass Highway, WA
    With the Columbia River in the background...
    [​IMG]

    More pics

    This thing is up to 300,000 + miles and adding fast. The 2.8L is starting to get tired and the 5 spd makes some interesting noises too. I did find a reciept in the glovebox for a rebuilt rear axle from 3-4 years ago so I think that the axle will probably out last the rest of the truck.
     
  2. Twiz

    Twiz 1/2 ton status

    Joined:
    Mar 8, 2001
    Posts:
    3,729
    Likes Received:
    0
    Location:
    Clearfield Ut.
    Cool, I've seen these things get a pile of miles on 'em with no complaints.

    I hope to get some miles out of mine.

    pictures of mine
    Dang near the best ride I've bought yet. Pathetic 2.2L, 5 spd. It fits the bill perfectly, nice lil run-about.
     
  3. kennyw

    kennyw N9PHW Premium Member

    Joined:
    Jun 9, 2002
    Posts:
    13,223
    Likes Received:
    94
    Location:
    Stevens Pass Highway, WA
    I forgot to mention the darn thing dropped dead on me a week ago... Traced it down to a blown fuse for the ECM, swapped in a spare ECM and it ran for about 5-10 minutes until I bumped it with another truck (parking it after using it to jump start the S10). Again blown fuse... I think there is a short in the wiring that plugs into the ECM and when I bumped it the ECM moved because it wasnt secured in place yet.
     
  4. H0BBEZ

    H0BBEZ Registered Member

    Joined:
    Sep 19, 2001
    Posts:
    38
    Likes Received:
    0
    Location:
    Frederick, CO
    Apparently you have to be careful about posting S-10 pictures around here. I added my S-10 Xtreme pictures to the S-Series area of the Photo Gallery just because it was empty at the time and got so much [I love Jeeps] for it that I eventually removed 'em.
     

Share This Page