Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Please Help!!! Important

Discussion in 'The Garage' started by chevyryan, Aug 1, 2006.

  1. chevyryan

    chevyryan Registered Member

    Joined:
    Aug 1, 2006
    Posts:
    13
    Likes Received:
    0
    Location:
    colorado
    i am 17 and i just swaped my motor myself and now i am having a miss fire that just keeps getting worse every time i drive it. its pretty much when im leaving a complete stop slowly and when im in low rpm while driving. also when i turn the truck on no codes or lights come on, but once i drive it a little the "check engine light" comes on, and it also wont pass emmisions. i am tryin to get it running decent because im movin to college at UTI in a week and i dont want to have any problems with it. any information would be great! i do have very old gas in it as well which could be part of it what should i do?
     
  2. big dan

    big dan 1/2 ton status Premium Member

    Joined:
    Aug 1, 2005
    Posts:
    2,656
    Likes Received:
    29
    Location:
    Arkansas
    more info on truck and year would be helpful. Have you checked all the plugs, wires, and distributor?
     
  3. Lenix

    Lenix Registered Member

    Joined:
    Apr 27, 2006
    Posts:
    14
    Likes Received:
    0
    Location:
    San Diego, CA.
    What year is it ???? TBI or carb.????? ----for starters check firing order, and remove one wire at a time looking for cuts and cracks. O and get some fresh gas in it.
     
  4. sweetk30

    sweetk30 professional hooker Premium Member

    Joined:
    Nov 1, 2004
    Posts:
    25,550
    Likes Received:
    543
    Location:
    horseheads , ny 14845
    and a good fuel filter.
     

Share This Page