Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

PLEASE HELP WITH THIS POS TBI

Discussion in 'The Garage' started by cavscout19delta, Feb 2, 2004.

  1. cavscout19delta

    cavscout19delta Registered Member

    Joined:
    Jan 18, 2004
    Posts:
    26
    Likes Received:
    0
    Location:
    Fort Knox , K.Y
    I just rebuilt my 87 jimmy and now it runs like its got 400000 miles on it.When i step into the pedal it stumbles all over its self. It acts like its flooding out or the timeing isnt advancing, I put new 02, fuel filter,plugs,cap,rotor, ect... plz some one help my first mud drag is this month and i cant show up like this /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/ears.gif /forums/images/graemlins/thumb.gif /forums/images/graemlins/k5.gif /forums/images/graemlins/peace.gif
     
  2. 91GMCSuburban

    91GMCSuburban 1/2 ton status

    Joined:
    Dec 9, 2002
    Posts:
    318
    Likes Received:
    0
    Location:
    San Antonio, TX
    Did you check your vacuum, injectors and fuel pump?
     
  3. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    are the injectors spraying a mist or are they dripping? if dripping then you need new injectors. Any codes stored? ALso when you set your timing, did you make sure you hooked up the tan wire you have to unhook when you set up timing?
     
  4. 84_Chevy_K10

    84_Chevy_K10 Banned

    Joined:
    May 30, 2001
    Posts:
    17,669
    Likes Received:
    0
    Location:
    IL, USA
    Do you have compression?
     
  5. 4xcrazy

    4xcrazy 3/4 ton status

    Joined:
    Oct 31, 2003
    Posts:
    9,471
    Likes Received:
    5
    Location:
    Olympia/Lacey, Washington
    I had that problem a few years back with mine, kept getting codes for oxygen sensor, changed it, then would get something else,looked at injectors and compared the spray pattern with a friend of mines engind,(same one) and mine just looked weak, turns out the fuel pump was going out and just wasn't pumping enough pressure to give it what it needed. If you have nearly 100k miles or more on it and have never changed the fuel pump, chances are that could be your problem.
     
  6. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    [ QUOTE ]
    <font color="red">I just rebuilt my 87 jimmy and now it runs like its got 400000 miles on it.When i step into the pedal it stumbles all over its self. It acts like its flooding out or the timeing isnt advancing,</font> I put new 02, fuel filter,plugs,cap,rotor, ect... plz some one help my first mud drag is this month and i cant show up like this /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/ears.gif /forums/images/graemlins/thumb.gif /forums/images/graemlins/k5.gif /forums/images/graemlins/peace.gif

    [/ QUOTE ]

    hehehe

    Distributor is 180 degrees out.
    When you install the timming chain with Dots facing each other that's NOT TDC. To get TDC both dots needed to be strait up. Remember the crank turns twice for every turn of the cam.

    Turn the engine by hand to TDC on the timing tab. Note the position of the rotor. Lift the dristributor straight up. Tun the crank one revolution till it comes back to TDC. Drop the distributor and try again.

    If it's not that hand you replaced the ballancer then you put the wrong one on. There are two different timing tab location and two different ballancers.
     
  7. cavscout19delta

    cavscout19delta Registered Member

    Joined:
    Jan 18, 2004
    Posts:
    26
    Likes Received:
    0
    Location:
    Fort Knox , K.Y
    im not 180 out because it only does it after it gets warmed up.when the motor is cold it has all the power at the pedal, thats why im stumped. /forums/images/graemlins/1zhelp.gif
     
  8. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    get a book and verify the O2 is working. If it's running cold and not hot that will lead you to think it has a issue with closed loop. That means problem with O2 and wires Or ECM issue.
     
  9. cavscout19delta

    cavscout19delta Registered Member

    Joined:
    Jan 18, 2004
    Posts:
    26
    Likes Received:
    0
    Location:
    Fort Knox , K.Y
    well this pos flashed two codes today, 32 and 45 . i know its not the oxygen sensor becasue its new.32 is the egr right? ill get a new one. would that make the motor stumble like that after it warms up?
     

Share This Page