Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Please help!!!!

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by alf4444, May 13, 2004.

  1. alf4444

    alf4444 1/2 ton status

    Joined:
    Nov 1, 2002
    Posts:
    2,051
    Likes Received:
    0
    Location:
    T-ville, ut.
    /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/1zhelp.gif
    Okay the vehicle involved is a 78 1/2 350/350/205 engine and all componants are NEW. Here is my problem. When the engine is cold it fires right up and Idles fine but it runs like a dog in gear- no real power. Last night I drove it 1/2 mile put gas in it and when I went to leave I had to fight to keep it running and had to keep it floored to keep it running and barely hit 25 MPH. It is a NEW holley reman quadrajet direct from Holley this is the second one I've got from them. All ignition parts have been replaced and were not the cause of the problem. It ran well enough and long enough to pass emmisions but it seems if I turn it off and then start it again is when the problems occur. Also it is a manual divrced chike setup. I want to hit the trail in this thing and I am really frustrated with this, I've been fighting this problem since feb. Also I am in a High altitude enviroment and holley told me they rejetted it for my elevation. Also black smoke come out of the exhaust when the problem is occuring, I think its still rich But??? /forums/images/graemlins/confused.gif
     
  2. big83chevy4x4

    big83chevy4x4 3/4 ton status

    Joined:
    Mar 22, 2002
    Posts:
    6,587
    Likes Received:
    0
    Location:
    Sheridan, Michigan
    sounds like it is extremely rich, you need to rejet it
     
  3. BlazerGuy

    BlazerGuy 3/4 ton status

    Joined:
    Apr 20, 2000
    Posts:
    9,206
    Likes Received:
    0
    Location:
    abcde
    Did you just bolt on the carb and go? /forums/images/graemlins/thinking.gif
     
  4. alf4444

    alf4444 1/2 ton status

    Joined:
    Nov 1, 2002
    Posts:
    2,051
    Likes Received:
    0
    Location:
    T-ville, ut.
    Holley said they already did that! /forums/images/graemlins/confused.gif
     
  5. ZZ4x4

    ZZ4x4 1/2 ton status

    Joined:
    Oct 17, 2001
    Posts:
    542
    Likes Received:
    0
    Location:
    Garland, TX
    Well, I gotta ask the basics since you haven't listed what your've checked already. Is the choke actually all the way open when the truck is warm? Has the timing been set and verified with vac adv disconnected? If you're seeing black smoke, it implies rich. Could be due to choke issues, too much jetting, pump squirt, pump cam, fuel pressure. Let us know what you've done so far...
    Jeff
     
  6. alf4444

    alf4444 1/2 ton status

    Joined:
    Nov 1, 2002
    Posts:
    2,051
    Likes Received:
    0
    Location:
    T-ville, ut.
    choke is wide open when warm, and it has a stock mech. fuel pump timing has been checked and rechecked.
     
  7. BlazerGuy

    BlazerGuy 3/4 ton status

    Joined:
    Apr 20, 2000
    Posts:
    9,206
    Likes Received:
    0
    Location:
    abcde
    [ QUOTE ]
    Holley said they already did that!

    [/ QUOTE ]

    I'll assume you were replying to me..

    The carb manufacturers try to get in the ballpark when they ship the carb. But it is up to you to do the tuning to get it to run right. Holley has no way of knowing how a carb will act on your engine, so they can't do any fine tuning...
     
  8. blueblaze

    blueblaze 1/2 ton status

    Joined:
    Dec 4, 2001
    Posts:
    274
    Likes Received:
    0
    Location:
    Salt Lake City, UT
    Do you know what jet's are in it? They should be stamped. I know Edelbrock does.
     
  9. alf4444

    alf4444 1/2 ton status

    Joined:
    Nov 1, 2002
    Posts:
    2,051
    Likes Received:
    0
    Location:
    T-ville, ut.
  10. alf4444

    alf4444 1/2 ton status

    Joined:
    Nov 1, 2002
    Posts:
    2,051
    Likes Received:
    0
    Location:
    T-ville, ut.
    [ QUOTE ]
    Do you know what jet's are in it? They should be stamped. I know Edelbrock does.

    [/ QUOTE ]

    I'm calling holley right now to find out, they come stock with 71's
     
  11. blueblaze

    blueblaze 1/2 ton status

    Joined:
    Dec 4, 2001
    Posts:
    274
    Likes Received:
    0
    Location:
    Salt Lake City, UT
    I would check and see if they really did change the jet's... /forums/images/graemlins/dunno.gif
     
  12. ZZ4x4

    ZZ4x4 1/2 ton status

    Joined:
    Oct 17, 2001
    Posts:
    542
    Likes Received:
    0
    Location:
    Garland, TX
    Gosh, the Rocky Mtn post is full of useful info for you. NOT. All the Holley bashing about not running on angles, and tuning, and it's not even a real Holley we're talkin about.
    Anywho, try tightening the secondary plate spring at the passenger side rear to make sure it doesn't open too soon. You could be flooding when the secondaries open too early. If the problem gets better this could be part of the problem. Also might look at Thirdgen.org . There is a wealth of Q-jet tuning wisdom there.
     
  13. Topdown

    Topdown 1/2 ton status

    Joined:
    Nov 26, 2002
    Posts:
    2,598
    Likes Received:
    0
    Location:
    Vancouver, Washington, U.S.A
    pull a plug and see how it looks... white - lean, black - rich...
     
  14. alf4444

    alf4444 1/2 ton status

    Joined:
    Nov 1, 2002
    Posts:
    2,051
    Likes Received:
    0
    Location:
    T-ville, ut.
  15. johnc

    johnc Registered Member

    Joined:
    May 6, 2004
    Posts:
    68
    Likes Received:
    0
    Location:
    O.C., CA.
    I don't know too much about q jet, but my buddys holly used to stick floats and just flood the engine, it would barely stay runnin unless it was floored, and it still lugged.... Just an idea /forums/images/graemlins/dunno.gif /forums/images/graemlins/dunno.gif
     
  16. alf4444

    alf4444 1/2 ton status

    Joined:
    Nov 1, 2002
    Posts:
    2,051
    Likes Received:
    0
    Location:
    T-ville, ut.
    Its got 69's in it what are you high altitude guys running in your qjets?
     
  17. nstarry

    nstarry 1/2 ton status

    Joined:
    Feb 13, 2004
    Posts:
    349
    Likes Received:
    1
    Location:
    st.cloud minnesota
    Hit it with a hammer see what happens /forums/images/graemlins/rotfl.gif /forums/images/graemlins/rotfl.gif /forums/images/graemlins/rotfl.gif
     
  18. alf4444

    alf4444 1/2 ton status

    Joined:
    Nov 1, 2002
    Posts:
    2,051
    Likes Received:
    0
    Location:
    T-ville, ut.
    I ordered a edelbrock 1405 we'll see what happens!
     
  19. blueblaze

    blueblaze 1/2 ton status

    Joined:
    Dec 4, 2001
    Posts:
    274
    Likes Received:
    0
    Location:
    Salt Lake City, UT
    [ QUOTE ]
    I ordered a edelbrock 1405 we'll see what happens!

    [/ QUOTE ]
    Did you get it yet?
     
  20. alf4444

    alf4444 1/2 ton status

    Joined:
    Nov 1, 2002
    Posts:
    2,051
    Likes Received:
    0
    Location:
    T-ville, ut.
    It showed up this morning at 7 /forums/images/graemlins/eek.gif (thanks Fedex) I should be able to get it on tonight!
     

Share This Page