Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

popping noise while turning

Discussion in 'The Garage' started by bigbadchev84, Jul 31, 2005.

  1. bigbadchev84

    bigbadchev84 1/2 ton status

    Joined:
    May 17, 2004
    Posts:
    2,191
    Likes Received:
    0
    Location:
    Hermiston, Oregon
    ok i got a 77' chevy 3/4 ton 4wd with a 4" lift and the raised steering arm, when turning the wheels back and forth you can hear a loud popping noise, i had my brother turning the wheel back and forth and can feel the pop through the back of the leafspring, the u-bolts are tight, what else should i check?
     
  2. hi pinion

    hi pinion 3/4 ton status

    Joined:
    Sep 25, 2003
    Posts:
    5,354
    Likes Received:
    0
    Location:
    **PLUMBING THE WORLD**
    sounds like a cracked frame bro, you need to get a repair brace for that. Ord has them i think. What it is, is the frame might be cracked, and its normally the case when you start lifing, etc, the added stress will crack the frame.
     
  3. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,583
    Likes Received:
    945
    Location:
    Massachussetts
    couple of things...

    Sheared center bolt in the leaf spring,bad bushings,cracked leaf,or frame cracked behind the steering box are common causes of popping noises..rusted ball joints or tie rod ends can 'pop"too....good luck!.. :crazy:
     
  4. foolhardy

    foolhardy Registered Member

    Joined:
    Sep 16, 2004
    Posts:
    84
    Likes Received:
    0
    check your drage links my k-5 was doing that for a while un tell it popped out :eek1:
     
  5. Thunder

    Thunder 3/4 ton status

    Joined:
    Jul 20, 2000
    Posts:
    8,946
    Likes Received:
    1
    Location:
    Northeast Nevada
  6. bigbadchev84

    bigbadchev84 1/2 ton status

    Joined:
    May 17, 2004
    Posts:
    2,191
    Likes Received:
    0
    Location:
    Hermiston, Oregon
    can you usually tell if it is cracked without removing the box?
     
  7. 1-bad-burb

    1-bad-burb Registered Member

    Joined:
    Jun 23, 2005
    Posts:
    93
    Likes Received:
    0
    Location:
    west virginia
    my 85 3/4 ton suburban with a 6" lift and 4" raised steering arm did the same exact thing, I replaced my ball joints, power steering box, drag link (replaced with 2" drop drag link), spring bushings, added the weld in frame brace, and I checked my tie rod ends which are fine, and replaced a broken center bolt in my left spring, fixed the problem for a while but it started doing it again which realy dissapointed me :mad:

    well I noticed my left front tire was low, so, I filled it to 35 psi AND.... the noise went away :confused: I love my old truck but sometimes it can be a real pain :mad:
     
  8. bigbadchev84

    bigbadchev84 1/2 ton status

    Joined:
    May 17, 2004
    Posts:
    2,191
    Likes Received:
    0
    Location:
    Hermiston, Oregon
    well the front end was gone through a few months ago, balljoints,wheel bearings, stabilizer, brakes, and tie rods, it usaully only pops at a complete stop turning the wheel back and forth
     
  9. pauly383

    pauly383 Daddy383 Staff Member Moderator

    Joined:
    Jul 22, 2001
    Posts:
    16,217
    Likes Received:
    1
    Location:
    Mesa , Arizona USA
    My original incarnation of my 83 did that , stock springs poly bushings . Only while stopped . Don't know which component did it , but my lift kit solved the problem . I reused the draglink , tierods etc . Only replaced springs , ubolts , steering arm and brakehoses . I had no broken centerpins or anything , just wavy springs . :dunno:
     
  10. Chaddy

    Chaddy 1/2 ton status GMOTM Winner

    Joined:
    May 23, 2005
    Posts:
    4,110
    Likes Received:
    2
    Location:
    Salt Lake City,Utah
    CRACKED FRAME. Easy fix! Get the weld on brace from ORD it fixed mine and I wheel the crap out of it
     
  11. bigbadchev84

    bigbadchev84 1/2 ton status

    Joined:
    May 17, 2004
    Posts:
    2,191
    Likes Received:
    0
    Location:
    Hermiston, Oregon
    does anyone have any pics of a cracked frame? do i have to remove the steering box to see if it is cracked? i went and pressure washed it and lokked, but i see no cracks.
     
  12. k20

    k20 3/4 ton status

    Joined:
    Sep 9, 2001
    Posts:
    5,068
    Likes Received:
    0
    Location:
    Mineral Springs, NC
    my does the same thing, but, i think its because I had a power steerin pump commit hiri kiri, and put all its fluid in my left front spring. Then it went and collected a buncha dirt. A temporary fix for me so far, has been to jack it up w/ the hilift off the bumper and let the susp flex, spray a buncha graphite powder in it, and itll be fine for a couple months, then it comes back.
     
  13. gone huntin

    gone huntin 1/2 ton status Premium Member

    Joined:
    Oct 25, 2004
    Posts:
    1,706
    Likes Received:
    1
    Location:
    Coldwater, MS
    My Suburban did this before my lift. It was the spring pack on the driver's side, the lower spring would "pop" side to side at the end from the upper spring. I tried tightening the u-bolts, but they weren't loose. Just watch the front of the spring pack while someone else turns the wheel back and forth. I put grease between the springs to resolve this. You could feel it in the floor board when it did it.
     
  14. Chaddy

    Chaddy 1/2 ton status GMOTM Winner

    Joined:
    May 23, 2005
    Posts:
    4,110
    Likes Received:
    2
    Location:
    Salt Lake City,Utah
    You can see a cracked frame just by looking around all the bolts and inside the frame and out all around the box. Mine was a hair line crack about 1 inch long right at the front of the box and it was popping like crazy and I first thought it was the springs but NOPE it was the frame.
     
  15. mjfoster49

    mjfoster49 Registered Member

    Joined:
    Nov 5, 2003
    Posts:
    95
    Likes Received:
    0
    Location:
    Tifton, Georgia
    Mine did that, but It was the center pin on the drivers side leaf spring.
     
  16. Jonny-K5

    Jonny-K5 1/2 ton status

    Joined:
    May 27, 2003
    Posts:
    1,654
    Likes Received:
    0
    Location:
    SoCal
    mine did the same thing, all new suspension/steering and the dang thing popped while turning. turned out to be a loose bolt on the bumper. just barely loose too. i tightened down all the bumper bolts, and all the bolts on the frame near the bumper. stuff loosens up with a lift.
     

Share This Page