Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

popping spring?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by denver75k5, Jun 12, 2001.

  1. denver75k5

    denver75k5 1/2 ton status

    Joined:
    May 15, 2001
    Posts:
    1,017
    Likes Received:
    0
    Location:
    Somewhere In The Woods
    when I turn the wheel, or accelerate hard, or flex the truck it
    "pops" . When having someone turn the wheel i can feel it mostley in the front drivers side leaf spring.
    If anyone has any idea what this is please let me know.
    e-mail Husky@apexmail.com
     
  2. Pugsley

    Pugsley 1/2 ton status

    Joined:
    Jan 16, 2001
    Posts:
    3,556
    Likes Received:
    0
    Location:
    Tucson, Arizona
    Mine used to do that, it turned out to be the swaybar. Is your rig lifted? And has your bar been dropped? Once I dropped my swaybar to compensate for the lift, It quit doing it.

    I'm so poor I can't even pay attention [​IMG]
    <A target="_blank" HREF=http://pugsley.coloradok5.com>http://pugsley.coloradok5.com</A>
     
  3. muddin4fun

    muddin4fun 3/4 ton status

    Joined:
    Feb 19, 2001
    Posts:
    5,644
    Likes Received:
    0
    Location:
    N Texas
    Sounds like ball joints. Lift the truck and see if you can wiggle the wheel either back and forth or side to side. It would help to have someone do that and you watch and see where the play it.

    <font color=purple>Have you hugged your K5 today?</font color=purple>
     
  4. UseYourBlinker

    UseYourBlinker 1 ton status

    Joined:
    Jun 7, 2000
    Posts:
    11,117
    Likes Received:
    0
    Location:
    .
    It would help if YOU FILLED OUT YOUR PROFILE!!

    You would get quicker answers.....


    <A target="_blank" HREF=http://community.webshots.com/user/vwryda>http://community.webshots.com/user/vwryda</A>
     
  5. 76chevy

    76chevy 1/2 ton status

    Joined:
    Aug 16, 2000
    Posts:
    246
    Likes Received:
    0
    Location:
    Utah
    Check the springs to see if they are loose. Mine does that also. If I make sure it is tight it quits for about a day and then comes back.

    All the bolts may need to be loosened and then retightened to get it to sit properly. I'm not sure. Also make sure your bumper mounts are tight along with the braces. They can move also due to frame flex.

    <font color=red>Spirit of 76</font color=red>
     
  6. denver75k5

    denver75k5 1/2 ton status

    Joined:
    May 15, 2001
    Posts:
    1,017
    Likes Received:
    0
    Location:
    Somewhere In The Woods
    Ya, My swaybar is no longer a part of my truck. It's lifted 6"
    the lift is fairly new, including all of the bushings ect.
     
  7. denver75k5

    denver75k5 1/2 ton status

    Joined:
    May 15, 2001
    Posts:
    1,017
    Likes Received:
    0
    Location:
    Somewhere In The Woods
    As for ball joints i guess that could be a cause , some time ago i had to tighten the upper joint ,,,,,REPLACEMENT TIME!!!!!
     
  8. DERBST

    DERBST Registered Member

    Joined:
    Jan 5, 2001
    Posts:
    15
    Likes Received:
    0
    Location:
    Texas
    Denver, it could also be the same problem I currently have a post for. Remove the nut off the front spring hanger to see if the hole is "wallered" out. If the spring bolts losin up over time they begin to wear up and down as the spring flexes up and down causing the hole to enlarge, thus cuasing your popping sound. Good Luck.
     
  9. CV202

    CV202 1/2 ton status

    Joined:
    Nov 14, 2000
    Posts:
    454
    Likes Received:
    0
    Location:
    Kingfield, ME
    I found that the rag joint of my steering column was hitting the inner fender well just barely. Every once in a while it would catch and "POP" when it got unhooked.

    Why do people keep calling it a Bronco!!!!! [​IMG]
     
  10. Grim-Reaper

    Grim-Reaper 3/4 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    7,385
    Likes Received:
    0
    Location:
    Atlanta
    Check your steering box and frame. could be a cracked frame poping.
    I have a pop that I was thinking was the spring...nope it's my 203 case thats still fulltime jumping.

    It's not my damn planet monkey boy!
    Grim-Reaper
     
  11. pcorssmit

    pcorssmit 1/2 ton status

    Joined:
    Jan 2, 2001
    Posts:
    1,346
    Likes Received:
    0
    Location:
    Denver, CO
    Mine started poping after I did the cross over, the second leaf moves around when you turn. No big deal.

    Pete

    '83 K5, 350 TBI (ex 6.2), 700R4, NP208, Dana 60/14 bolt, 4.56s, Detroits, 3" lift, 15-39.5x15 TSLs
    '97 Dodge 2500 4x4 CC LB Sport, Cummins 5 spd
     
  12. taterblazer

    taterblazer 1/2 ton status

    Joined:
    Feb 2, 2001
    Posts:
    277
    Likes Received:
    0
    Location:
    Boise, ID
    Mine makes that popping, creaking sound also. I decided to ignore it! LOL. I would check your ball joints though and any thing that could be a safety hazard. My theory is body flex.
     
  13. walt88

    walt88 1/2 ton status

    Joined:
    May 24, 2000
    Posts:
    430
    Likes Received:
    0
    Location:
    Monmouth County, NJ
    Mine does due to bad body mounts. Give that a look.

    <font color=red>1988 Chevrolet K5 Blazer, Middletown, NJ (07737).</font color=red>
     

Share This Page