Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Power Steering pump worn out?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by mountainexplorer, Jul 9, 2002.

  1. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    I got my Crew Cab stuck last friday and ever since then, my steering has been hard. I tightened the PS belt as tight as it would go, but at idle or low RPM, it acts like the belt is slipping (even though it's not- no squeeling or anything). At higher RPM's, it steers easier. The pump is full of fluid, and not leaking, so could the pump have just wore out?
     
  2. muddysub

    muddysub 1 ton suburban status Staff Member Moderator GMOTM Winner

    Joined:
    Jun 23, 2001
    Posts:
    10,451
    Likes Received:
    489
    Location:
    my garage, Henderson, NV
    if it is the original one i would say yes, i got my sub stuck in the mud and it fried my pump.
     
  3. mountainexplorer

    mountainexplorer 1/2 ton status

    Joined:
    Nov 14, 2001
    Posts:
    4,903
    Likes Received:
    0
    Location:
    Spokane, Wa./Ione, Wa
    That probably explains why my brake pedal feels real hard now too. It's a 1-ton with the Hydro-Boost setup, and ever since the steering got hard, so did the brake pedal.
     

Share This Page