Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Pressure washer Q...

Discussion in 'The Tool Shed' started by 84gmcjimmy, Aug 23, 2006.

  1. 84gmcjimmy

    84gmcjimmy 1 ton status

    Joined:
    Dec 3, 2003
    Posts:
    12,838
    Likes Received:
    0
    Location:
    B.C. CANADA
    My mom's boyfriend got a pressure washer from us for his birthday...
    I went to use it yesterday night to finish washing the jimmy...
    Filled it up with gas, put the garden hose on along with the pressure hose and gun. Turned it on and there was 0 pressure.

    What would cause this? There is lots of pressure coming from the water hose, nothing blocking the water filter, nothing clogging the hoses as far as I could tell(blew through them) and no SERIOUS leaks...

    Anyone?
     
  2. BigOrange90Jimmy

    BigOrange90Jimmy 1/2 ton status Premium Member

    Joined:
    May 24, 2002
    Posts:
    2,923
    Likes Received:
    0
    Location:
    Wilmington, NC
    Someone allowed it to run dry, allowed water to freeze in it, or the crankshaft key is sheared.
     
  3. 78Buford

    78Buford 1/2 ton status

    Joined:
    Apr 1, 2005
    Posts:
    264
    Likes Received:
    0
    Location:
    Ohio
    How long did you let it run? The one I have takes close to a full minute to put out any pressure...once it has pressure, you can use it continuously without it losing pressure. The one I have is a Campbell Hausfield from Walmart...under $200.
     
  4. Drey

    Drey 3/4 ton status

    Joined:
    May 8, 2003
    Posts:
    8,288
    Likes Received:
    0
    Location:
    Iowa
    when you turn on the hose and pull the trigger will water come out of the wand without having the pressure washer turned on? It should.


    My guess is the pump was allowed to feeze and is fubared or it just lost its prime and maybe is "stuck"
     
  5. badfish4tail

    badfish4tail 1/2 ton status

    Joined:
    Mar 1, 2005
    Posts:
    1,684
    Likes Received:
    1
    Location:
    Long Beach
    Make sure the garden hose is turned on first before you try and start it, thats what also happend to me.
     

Share This Page