Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Previous Owners suck thread...

Discussion in 'The Garage' started by sled_dog, Feb 5, 2004.

  1. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    I know there have been plenty but now I have another vehicle to complain about. I do maintenence on my Suburban in between customers at work. Check fluids and everything trying to see if there are any leaks. So far everything is fine, I finally decide to pull the air cleaner lid off and look at the filter. I go to do it and the lid won't come off! I figure its rusted on so I pull the whole assembly off. Use some carb cleaner and clean up the TB which is pretty cruddy. I look closer at the air cleaner and realize the PO used black rtv and glued the air cleaner lid to the air cleaner assembly! He must have thought it didn't seal well enough or something. /forums/images/graemlins/doah.gif /forums/images/graemlins/doah.gif /forums/images/graemlins/doah.gif /forums/images/graemlins/doah.gif /forums/images/graemlins/doah.gif /forums/images/graemlins/doah.gif /forums/images/graemlins/doah.gif
     
  2. Tweetysuarus

    Tweetysuarus 1/2 ton status

    Joined:
    May 25, 2002
    Posts:
    2,294
    Likes Received:
    0
    Location:
    Lynnhood,WA
    I had a 383 I purchased years ago that some POS /forums/images/graemlins/angryfire.gif used JB Weld to keep the distributor from slipping! /forums/images/graemlins/angryfire.gif What a PIA it was to get that distributor out and clean out the clamp bolt hole! /forums/images/graemlins/angryfire.gif! Stupid people shouldn't breed!
    Bill
     
  3. atlantak-5er

    atlantak-5er 1/2 ton status

    Joined:
    Aug 20, 2003
    Posts:
    225
    Likes Received:
    0
    Location:
    Atlanta, GA
    My 75 had ghetto blue home carpet /forums/images/graemlins/peace.gif inside it with some of those rear capitans' chairs out of a mid seventies conversion van. It also had some half arse rigged stereo system that almost burned my K5 to the ground the 1st day i bought it! The second day I had it I gutted it and lined the tub!
     
  4. rjfguitar

    rjfguitar 3/4 ton status GMOTM Winner

    Joined:
    Aug 28, 2002
    Posts:
    9,097
    Likes Received:
    144
    Location:
    california
    [ QUOTE ]
    Stupid people shouldn't breed!


    [/ QUOTE ] No kidding! I agree! /forums/images/graemlins/ignore.gif /forums/images/graemlins/shame.gif
     
  5. tweek

    tweek 1/2 ton status

    Joined:
    Aug 13, 2003
    Posts:
    353
    Likes Received:
    0
    Location:
    montgomery, ny
    some retard mixed concrete in the back of my pre-owned k5 /forums/images/graemlins/dunno.gif then thought if he vacuumed the rug no harm no foul.......however the lie in the cement ate away the tail pan /forums/images/graemlins/angryfire.gif....that was the only piece of rust on my truck........since been replaced..........the nerve of that S.O.B for using the truck the way he needed /forums/images/graemlins/doah.gif
     
  6. gravdigr

    gravdigr 1/2 ton status

    Joined:
    Apr 15, 2003
    Posts:
    1,129
    Likes Received:
    0
    Location:
    Tyrone, PA
    Got ya all beat. My PO ordered the blazer from the factory with 2.73 gears "to improve towing performance in the mountains"...yes he actually said that to my face when I bought it. It's ok though his eyes looked a little funny so i think he just finished hitting his crack pipe.
     
  7. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    oh if you want to talk PO of K5s, my PO told me the K5 had a crate 350 and 3.73 rears. Truth? stock factory 305 that burned oil like mad and died on me. Rear? 2.73 gears with a bad pinion bearing.
     
  8. K1Orion

    K1Orion 1/2 ton status

    Joined:
    Jan 8, 2003
    Posts:
    812
    Likes Received:
    1
    Location:
    st.louis,MO
    [ QUOTE ]
    some retard mixed concrete in the back of my pre-owned k5

    [/ QUOTE ]

    /forums/images/graemlins/histerical.gif /forums/images/graemlins/histerical.gif /forums/images/graemlins/histerical.gif /forums/images/graemlins/histerical.gif


    My dad's neighbor used a bunch of bags of quikrete for weight in the bed during the witer a couple years ago. Needless to say, when the snow melted he had a hard time gettin the concrete chunk the width of the bed out.


    [ QUOTE ]
    Stupid people shouldn't breed!

    [/ QUOTE ]
    And unfortunately the guy had more kids than fingers. /forums/images/graemlins/rolleyes.gif
     
  9. jjlaughner

    jjlaughner 3/4 ton status

    Joined:
    Jan 12, 2001
    Posts:
    7,406
    Likes Received:
    0
    Location:
    Indiana
    previous owner put a new tailpan in......


    Of course he didn't hook the fenders back to it, and stupid me when I heard tailpan was fixed I ASSUMED the floor was OK /forums/images/graemlins/rolleyes.gif


    PO, put on a newer tailgate.......

    NO key and it doesn't lock and the tailgate handle is broke /forums/images/graemlins/doah.gif


    had a return fuel line leak....

    PO, cut the lines and spliced in rubber lines
    PO also replaced the brake lines with the cheap roll lines and never hooked them up to the frame or axles... the lines just ran which ever way and was hanging /forums/images/graemlins/angryfire.gif
     
  10. 75-K5

    75-K5 3/4 ton status

    Joined:
    Apr 28, 2002
    Posts:
    5,353
    Likes Received:
    0
    Location:
    Anderson, Indiana
    Hmm, the only thing I can blame my PO for is plowing snow all winter then parking it all summer without so much as a spray with the hose /forums/images/graemlins/shame.gif

    Actually, I'm the idiot PO who people will blame in the future. I do so many half-assed and crazy fixes to my truck it's ridiculous. /forums/images/graemlins/peace.gif
     
  11. screamer*145

    screamer*145 1/2 ton status

    Joined:
    Oct 23, 2003
    Posts:
    174
    Likes Received:
    0
    Location:
    cottage grove, mn
    my PO had a rope to hold the trans/transfer case adapter to the crossmember. /forums/images/graemlins/shame.gif

    PO said the motor had been rebuild and about 4 months later it took a crap when I found coolent in the oil pan /forums/images/graemlins/doah.gif!
     
  12. boggerless

    boggerless 1 ton status Premium Member

    Joined:
    May 26, 2003
    Posts:
    22,728
    Likes Received:
    96
    Location:
    dearborn heights, Michigan
    the PO of mine drilled 2in holes in the bottem of the air cleaner box BETWEEN the carb and filter. /forums/images/graemlins/confused.gif /forums/images/graemlins/k5.gifto /forums/images/graemlins/truck.gif
     
  13. sled_dog

    sled_dog 1 ton status

    Joined:
    Sep 3, 2002
    Posts:
    16,870
    Likes Received:
    0
    Location:
    Austin, TX
    [ QUOTE ]

    PO also replaced the brake lines with the cheap roll lines and never hooked them up to the frame or axles... the lines just ran which ever way and was hanging /forums/images/graemlins/angryfire.gif

    [/ QUOTE ] Mine did the samething but he informed me of it before I bought the burban and made sure it was ok by me.
     
  14. Roshambo

    Roshambo Registered Member

    Joined:
    May 1, 2003
    Posts:
    50
    Likes Received:
    0
    Location:
    South Coast, OR
    Well, I bought my truck with a tired 350, it originally came with a 400 but running the block numbers told me otherwise.. I figured I would wheel it until it went because I had a motor already built up anyways. When I got a rod knock I decided it was time to pull it out.

    I already knew the previous owner was an idiot, but when I started pulling the motor I was amazed. All of the motor mount bolts were finger loose. The TQ convertor was missing bolts and the ones that were there were mismatched... basically it seemed like whoever did the half ass job of installing the POS motor forgot to torque down anything. /forums/images/graemlins/doah.gif

    -Joe
     

Share This Page