Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Problem-----Lights and horn stoped working HELP!!!!

Discussion in 'The Garage' started by y5mgisi, Dec 29, 2002.

  1. y5mgisi

    y5mgisi 1 ton status

    Joined:
    Aug 11, 2002
    Posts:
    17,156
    Likes Received:
    247
    Location:
    Portland Oregon
    Went to turn my lights on the other day and i get nothing /forums/images/graemlins/mad.gif, then i dont remember why but i hit y horn and it dosnt work either /forums/images/graemlins/mad.gif /forums/images/graemlins/mad.gif....thenh a couple days later i hit the lights and they work! /forums/images/graemlins/laugh.gif and just for the hell of it i hit the horn and it works too /forums/images/graemlins/laugh.gif!! now neither of them works again. /forums/images/graemlins/mad.gif I checked and repalced all the fuses and still nothing /forums/images/graemlins/confused.gif....so I ask my uncle what he thought /forums/images/graemlins/1zhelp.gif and he says that they both run on the same circut I.E. the same relay... So my question to you is, what the hell is wrong!! is there a comon relay between the two that just needs replacing or what??? /forums/images/graemlins/confused.gif /forums/images/graemlins/1zhelp.gif /forums/images/graemlins/truck.gif

    Thanks alot......Mitchell
     
  2. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,178
    Likes Received:
    1,387
    Location:
    E-town baby!
    Check the ground wires at the core support...both the lights and the horn get their ground there. You may have a badly cooroded or loose ground wire...

    rene
     
  3. y5mgisi

    y5mgisi 1 ton status

    Joined:
    Aug 11, 2002
    Posts:
    17,156
    Likes Received:
    247
    Location:
    Portland Oregon
    Man thats a great idea!! ok i'll go check that and tanks alot for replying. I'll let ya know if it did or didnt work. Again thaks alot /forums/images/graemlins/thumb.gif
     
  4. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,178
    Likes Received:
    1,387
    Location:
    E-town baby!
    Keep us posted in case that wasn't it.

    rene
     
  5. y5mgisi

    y5mgisi 1 ton status

    Joined:
    Aug 11, 2002
    Posts:
    17,156
    Likes Received:
    247
    Location:
    Portland Oregon
    AHHHH!!!! ground is all fine.....what else could it be?? Now when i say no lights i meen NO LIGHTS no dash lights no marker lights no high beems no low beems nuthin, but the blinkers work though
     
  6. tRustyK5

    tRustyK5 Big meanie Staff Member Super Moderator GMOTM Winner Author

    Joined:
    Jul 23, 2000
    Posts:
    36,178
    Likes Received:
    1,387
    Location:
    E-town baby!
    It's a long shot but check the dimmer switch on the floor. Unplug it and check with a test light that you have 12 volts coming to it with the headlight switch on. If you have 12 volts there and the lights don't work the switch could be bad. If you don't have 12 volts there with the switch on it's somewhere else in the circuit.

    You can do the same with the headlight switch. Unplug it and check it with a test light. At least one prong should have 12 volts. If you have 12 volts coming to the switch the problem could be there too. I would make a jumper wire with a male spade connector on each end. Find the spot with 12 volts and plug one end of the jumper in that hole. Now plug the other end into the other slots one at a time and see what works and what doesn't. If you can manually get park lights and headlights using the jumper the headlight switch is FUBAR.

    Rene
     
  7. 72BlazerTravis

    72BlazerTravis Registered Member

    Joined:
    Dec 19, 2002
    Posts:
    55
    Likes Received:
    0
    Location:
    Jefferson City, Missouri
    Grounds may look good but they can suck. My damn truck is draining batteries in like 15 minutes cause the ground to the chassis sucks. If it's an electrical problem 99% of the time it's the ground.
     

Share This Page