Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Problem starting, ECM?

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by rem7600, Sep 15, 2001.

  1. rem7600

    rem7600 1/2 ton status

    Joined:
    Apr 16, 2000
    Posts:
    125
    Likes Received:
    0
    Location:
    Coeur d\'Alene, Idaho
    89 w TBI 5.7
    Can an ECM (Electronic Control Module) on the distributor fail
    intermittently or is it typically an ALL or nothing problem?

    I've had 2 instances (over the last month) where the truck
    turns over and over and over and doesn't want to start. I
    can smell fuel so I think it's spark related. Truck normally runs
    great and idles quite smoothly. Other thoughts or things to
    check?

    Any help/suggestions will be welcomed and appreciated!

    REM7600

    <a target="_blank" href=http://www.geocities.com/rem7600/>http://www.geocities.com/rem7600/</a>
    <font color=purple>REM7600 - '89 Jimmy</font color=purple>
     
  2. Chris Demartini

    Chris Demartini 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    2,406
    Likes Received:
    1
    Location:
    Dumont NJ 07628
    <font color=blue>Take out a plug and lay it against the motor while someone cranks it and check if its getting spark. Do this for each one. Also check that your getting 12v to the coil. All the ECM controls is advance.
     
  3. SWAMPRNR

    SWAMPRNR 1/2 ton status

    Joined:
    Apr 7, 2001
    Posts:
    296
    Likes Received:
    0
    Location:
    Temple Texas
    The ECM controls the distributor.If it goes out you will have no spark.You can have it tested at most part stores to see if thats your problem.

    A BIG HAMMER CAN FIX ANYTHING.. [​IMG]
     
  4. 4x4k20

    4x4k20 1/2 ton status

    Joined:
    Mar 17, 2001
    Posts:
    1,699
    Likes Received:
    0
    Location:
    williamson ga.30292
    replace your fuel pump and you will be fine to go

    4x4k20
     
  5. rem7600

    rem7600 1/2 ton status

    Joined:
    Apr 16, 2000
    Posts:
    125
    Likes Received:
    0
    Location:
    Coeur d\'Alene, Idaho
    If it were the fuel pump (and I'm not saying that it's NOT), then why would it be so sporadic? Like I said in the original post, it's only happened 2 times. I would say over the course of a little over a month.

    REM7600

    <a target="_blank" href=http://www.geocities.com/rem7600/>http://www.geocities.com/rem7600/</a>
    <font color=purple>REM7600 - '89 Jimmy</font color=purple>
     
  6. rem7600

    rem7600 1/2 ton status

    Joined:
    Apr 16, 2000
    Posts:
    125
    Likes Received:
    0
    Location:
    Coeur d\'Alene, Idaho
    Hey BG71,

    I'm assuming you mean the next time I see the problem, YES? Or do you mean right now while it is not experiencing any troubles?

    REM

    <a target="_blank" href=http://www.geocities.com/rem7600/>http://www.geocities.com/rem7600/</a>
    <font color=purple>REM7600 - '89 Jimmy</font color=purple>
     

Share This Page