Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

problems running, HELP!

Discussion in 'The Garage' started by 76blazerguy, Apr 8, 2005.

  1. 76blazerguy

    76blazerguy 1/2 ton status

    Joined:
    Nov 15, 2004
    Posts:
    125
    Likes Received:
    0
    Location:
    wichita, Kansas
    i just bought installed a new intake manifold and put everything back together. I dont think i have left anything or fergotten anything. It turns over and begins to idle, then there is a bang and smoke exits from the carb. its a grey smoke. I dont know how to describe it other than a back fire. The truck then shuts off. Just incase you need to know its a stock 350 with verylittle modifications on it. Any ideas guys????
     
  2. Mad-Dog

    Mad-Dog 1/2 ton status

    Joined:
    Mar 20, 2005
    Posts:
    548
    Likes Received:
    0
    Location:
    Ocklawaha,Fl
    Sounds like you got the distributor in 180 out or the initial timing is way off or you could have a couple wires crossed.
    Are you sure that the motor is not sucking air from somewhere besides the carb. ?
     
  3. bigcat44

    bigcat44 Registered Member

    Joined:
    Jan 29, 2005
    Posts:
    59
    Likes Received:
    0
    Location:
    Albuquerque
    went through this same crap the other day. Start with your hoses, be sure they are connected correctly, then check your distributor and wires. Before you flip your distributor, adjust your timing to see if that corrects it. With my dist flipped 180 out my TBI Jimmy would not start.
     
  4. 76blazerguy

    76blazerguy 1/2 ton status

    Joined:
    Nov 15, 2004
    Posts:
    125
    Likes Received:
    0
    Location:
    wichita, Kansas
    ok well i got it running, and idles good. The only problem now is when i give it some gas it backfires out the exhuast now. I have never had that problem before so im confused what is making it do it now. Is that still a timing issue??
     
  5. bigcat44

    bigcat44 Registered Member

    Joined:
    Jan 29, 2005
    Posts:
    59
    Likes Received:
    0
    Location:
    Albuquerque
    Sounds like it is a timing issue
     
  6. Mad-Dog

    Mad-Dog 1/2 ton status

    Joined:
    Mar 20, 2005
    Posts:
    548
    Likes Received:
    0
    Location:
    Ocklawaha,Fl
    Advance the timing some more....and check to make sure the rockers are'nt overtightened (zero lash + half a turn)
     
  7. 76blazerguy

    76blazerguy 1/2 ton status

    Joined:
    Nov 15, 2004
    Posts:
    125
    Likes Received:
    0
    Location:
    wichita, Kansas
    all fixed guys, and loving the intake now. thanks for everyones help
     

Share This Page