Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

PS Pulley Install??

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Boss, May 21, 2001.

  1. Boss

    Boss 1/2 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    2,550
    Likes Received:
    0
    Location:
    Maryland
    Hello,
    I'm having major trouble putting my Power Steering Pulley back onto my Power steering Pump. I have to have the pump/reservoir, in the truck before I can put the pulley back on, which makes it a major pain.
    But, I just can't get the pulley back on. Then I noticed that the PS pump shaft is threaded in there, so I'm thinking I need a screw or something to get it in. Anyone know the size bolt or if this is really the way to do this? Thanks in advance.
    Boss

    <A target="_blank" HREF=http://www.boss.coloradok5.com>http://www.boss.coloradok5.com</A>
     
  2. FRIZZLEFRY

    FRIZZLEFRY 1/2 ton status

    Joined:
    Apr 20, 2001
    Posts:
    3,271
    Likes Received:
    134
    Location:
    Clovis CA
    Ive got a p/s pulley remover / installer kit I use. The instaler threads into the end of the shaft and theres a nut on the installer u crank down on to sort of press the pulley back on. I guess u could use a long bolt with a nut for the same sort of deal.Some auto parts places migt rent these things.That might be your best bet.

    All work and no beer makes Frizz a dull boy
     
  3. Boss

    Boss 1/2 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    2,550
    Likes Received:
    0
    Location:
    Maryland
    Thanks Friz.
    Yeah, I got the pulley puller, but not installer. I figured that was it. My puller doesn't screw into the shaft on the pulley. I guess, I'll be headed to the Hardware store today!!
    Boss

    <A target="_blank" HREF=http://www.boss.coloradok5.com>http://www.boss.coloradok5.com</A>
     
  4. Esteban86K5

    Esteban86K5 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    3,712
    Likes Received:
    0
    Location:
    Bakersfield, CA
    When I got my PS pump, It came with the bolt and nut to install it. It was just a normal bolt, nut and washer. Hardware store should definately have it. BTW why did you have to install it first then put the pulley on? Just wondering?

    <font color=blue>Esteban</font color=blue>

    <font color=red>SEMPER FI TO MY BLAZER
     
  5. Boss

    Boss 1/2 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    2,550
    Likes Received:
    0
    Location:
    Maryland
    Yep, had to install the pump first, then I could put the pulley on. B/c the pulley blocks the bolts that screws through the brackets and pump. A big pain this way!

    But, I did get the bolt and nut/washer and tried it. It worked for a little while, BUT, I bent 3 bolts and broke on while the thread was still in the pump!! But I did manage to get it out though. :) (thank God)
    So, now I'm thinking of looking for grade 8 stuff to do it. I have about 1/4" more to go!! My big problem now, is that I think AGR sent me the wrong Steering gear box, b/c none of my hoses (pressure or return hose) from the pump will screw into the gear box! I'm thinking they sent me the flare fitting one, when I specifically requested the O-ring type! The part # on it even states for O-ring fitting only!! Oh well. thanks for the help guys.
    Boss

    <A target="_blank" HREF=http://www.boss.coloradok5.com>http://www.boss.coloradok5.com</A>
     

Share This Page