Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Q's after new engine install, trans not hooked up right??

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by k30gambi, Dec 29, 2002.

  1. k30gambi

    k30gambi 1/2 ton status

    Joined:
    Dec 24, 2001
    Posts:
    108
    Likes Received:
    0
    Location:
    illinois
    Q\'s after new engine install, trans not hooked up right??

    Just got done putting a rebuilt 350(9-1comp, 210/218@.050 cam, edelbrock manifold & 600 performer) in little brothers K10. The thing really runs, but at 1/2 throttle it seems like it shifts too soon, it immediately goes through to high gear (TH350). And at full throttle it shifts really slow from 1st to 2nd gear which was really crisp before. Wish we could find a way to get a few more rpm's out of each shift, maybe we should get a shift kit? /forums/images/graemlins/1zhelp.gif
     
  2. bablazer73

    bablazer73 1/2 ton status

    Joined:
    Apr 4, 2000
    Posts:
    3,363
    Likes Received:
    0
    Location:
    upstate ny
    Re: Q\'s after new engine install, trans not hooked up right??

    B@M makes adjustable vacuum modulaters and adjustable governers for these trannys to fine tune shift points.
     
  3. cybrfire

    cybrfire 1 ton status Vendor GMOTM Winner

    Joined:
    Dec 15, 2002
    Posts:
    15,139
    Likes Received:
    565
    Location:
    Iowa
    Re: Q\'s after new engine install, trans not hooked up right??

    A B&M Off road HD shift kit will help the slow shifting also. Crucial if you run in any sand or mud.
     

Share This Page