Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Quadrajet question

Discussion in 'The Garage' started by BlahBlah, Apr 8, 2006.

  1. BlahBlah

    BlahBlah Registered Member

    Joined:
    Apr 13, 2005
    Posts:
    10
    Likes Received:
    0
    Location:
    Oregon
    Do they make a quadrajet with mechanical secondaries or are they all vacuum? I'm guessing that they are all vacuum. If so then is there a way to get rid of some of the lag when you go full throttle? I've got the Edlebrock performer on my motor now and love the throttle response, but even with the offroad kit even looking at a hill makes it stall. I'm putting a new motor in so maybe it would be worth it to buy a truck avenger. Gimme some ideas guys any help will be appreciated.
     
  2. Matstro

    Matstro Newbie

    Joined:
    Jan 26, 2006
    Posts:
    3
    Likes Received:
    0
    Location:
    Winnipeg, Manitoba, Canada
    If you have lag or bog when you tromp the throttle that means the seconderies arn't adjusted properly. The adjustment procedure is not complicated on a standard Rochester but I am not certain about the Edelbrock.
     
  3. hack500

    hack500 1/2 ton status

    Joined:
    Sep 16, 2005
    Posts:
    523
    Likes Received:
    0
    Location:
    Templeton, Ma
    if you're getting a secondary-bog, iirc, likely means that the secondary air doors are opening too fast.
     

Share This Page