Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

question about 700r4

Discussion in 'The Garage' started by George_Pimpdaddy, Jul 1, 2006.

  1. George_Pimpdaddy

    George_Pimpdaddy 1/2 ton status

    Joined:
    Oct 17, 2002
    Posts:
    1,306
    Likes Received:
    1
    Location:
    Edmonton Alberta Canada
    in my 89 blazer first gear will rev out to about 2600-3200 is this normal after it will shift fine but doing like 30km is a bit of a rev. also my speedo cable is not working right now the green gear is rubbed down so im on the hunt for a new one, but will that make the tranny act up? im planing on getting a tranny flush really soon and some new lines made up too. thanks for any insight.
     
  2. NateInChandler

    NateInChandler 1/2 ton status

    Joined:
    Apr 23, 2006
    Posts:
    418
    Likes Received:
    0
    Location:
    Chandler, AZ
    Make sure if you do a flush to change the filter first. Ive seen some of those jiffy lubes do flushes without doing a service first and seriously screw stuff up.If you want you can do it on your own, just unhook the return line from the radiator and put a hose on it going into a bucket, if youve done a service, put 4 quarts in the trans and start the truck, pour another 4 quarts in and let the tranny pump all the fluid out into the bucket, now just re-fill (about 4 quarts) and you should be fine... of course after hooking the return line back up. hehe. First gear on a 700 is pretty low, normally the 1-2 on a 700 is pretty quick but it sounds like someone has messed with the governer or tv valve.. Nate
     
  3. NEK5

    NEK5 3/4 ton status Premium Member

    Joined:
    Oct 25, 2005
    Posts:
    9,843
    Likes Received:
    37
    Location:
    Ipswich MA
    check your tv cable??
     

Share This Page