Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

?!?!Question about performance on the new GM 5.3L?!?!

Discussion in 'Other Rides' started by 87K54WD, May 25, 2002.

  1. 87K54WD

    87K54WD 1/2 ton status

    Joined:
    Mar 23, 2000
    Posts:
    105
    Likes Received:
    0
    Location:
    Texas
    I've got a 2001 Z71 with the 5.3L and tonight I had to "punch it" from about 40 mph on a slight uphill and it started making a rapid ticking sound that I could feel thru the gas pedal. What gives? Was this pinging / knocking / detonation??? It went away as soon as I let off the gas. I only use 93 Octane from Exxon, Mobil, or Chevron. It has around 9K on it now. I've noticed since we bought the thing new that the 5.3L seems kinda of sluggish when you get on her. Any one else have this problem with the 5.3L? The noise from the engine really has me worried. One other time in the past, I got on the gas hard from a dead stop I got the rotten egg smell. Have yet to have a SES / check engine soon light. By the way, I only use Mobil 1 oil in it. Also, would it have been better to hit the tow/haul button before I got on it OR should I have dropped it down to 3rd gear myself OR both??? Really need some insight here.
     
  2. BowtieBlazer

    BowtieBlazer 1/2 ton status

    Joined:
    Jul 15, 2001
    Posts:
    2,462
    Likes Received:
    0
    Location:
    Baton Rouge, Louisiana
    I have experience with two 5.3's one in a 01' GMC extended cab never had any sluggishness off the line or from a rolling hammer down! Also drove a 01' Chevy Z71 regular cab with 35's and it had plenty of power with the 5.3 and no sluggishness. Could it be a fried cat. convertor? The way these trucks are made today you should be able to punch it from an speedwithout down shifting or hitting the tow button, unless you had a trailer behind it.
     
  3. MudNurI

    MudNurI 1/2 ton status

    Joined:
    Jul 15, 2001
    Posts:
    2,113
    Likes Received:
    0
    Location:
    VT
    You don't need to use the tow/haul button unless your towing. We had the same truck as you- cept it was a 99. and it had more than enough power...never had a problem dropping down a few gears if I wanted her to..seems to me you need a "reflash"...the computer's in these things have to be updated. your dealer may not update it unless you can come up with an actual complaint..however I think your knocking or pinging is enough...If you have a good relationship with your service manager, he may just update it if you ask him..if not your going to have to find an actual complaint, and then go in and "tell them you have it"..I'll head over to <a target="_blank" href=http://www.thedieselpage.com>www.thedieselpage.com</a> later and see if I can find the link to a page where you put your VIN in, and it offers you all the updates available for the said vehicle. It also tells you what they address, so you can "tell them you have it" even if you don't.

    BTW.. wanna lift your rig? Brand New Rancho 4" sitting in my garage, waiting for a new home!..it doesn't fit our new 2500 HD...

    Brandy
     

Share This Page