Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Questions on engine swap

Discussion in 'The Garage' started by getitup, Jun 3, 2003.

  1. getitup

    getitup Registered Member

    Joined:
    Apr 27, 2003
    Posts:
    35
    Likes Received:
    0
    Location:
    Hazelwood, MO
    Well the six cylinder is out and the 350 is in the 75 Jimmy. The engine was given to me from a good friend. It is all stock except for a edelbrock intake and a set of headers. It starts and runs good, but I am having a few problems.

    1. Everytime I let off the gas I get a loud pop from the exauhst. I was running it open headers at first so I put on a set of glass packs because I thought it was the fact that I had no exaust and it was sucking air back into the headers. Even with the glass packs it still does it. I have retarded and advanced the timing and still the same. I have run it rich and lean and in the middle and no change. It doesnt matter if it is gear or park. /forums/images/graemlins/1zhelp.gif

    2. My six cylinder fuel pump did not have a fuel return line. The 350 fuel pump does. For now I have just capped it off to get it running. Could this be part of the problem in the first question. Is it giving the carb to much fuel so even when I try to make it lean it still runs rich? I would imagine that my fuel tank does not have a place to run a return line so would I just be able to loop the return line back to the supply line?
     

Share This Page