Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

quick alternator wiring question - 89 sub

Discussion in 'The Garage' started by mouse, Jan 11, 2006.

  1. mouse

    mouse 1/2 ton status

    Joined:
    Nov 10, 2003
    Posts:
    1,448
    Likes Received:
    0
    Location:
    Great Falls Mt
    I'm trying to finish up some of the wiring on my blazer since converting to the TBI and sepentine system from the 1989 suburban I bought. I have taken many pictures so I would see where things went, but the alternator wiring is not as clear as I would like in the few pics I took of it.

    It appears that there are two 10 or 12 gauge wires that attach to the output lug. One goes to the power block on the firewall, and the other to the passenger side of the engine.

    I have 2 questions:

    1. Do both wires attach to the output lug?
    2. Where does the wire go on the passenger side? - the starter or the battery.

    My guess is yes and starter.
     
  2. diesel4me

    diesel4me 1 ton status Premium Member

    Joined:
    Jul 24, 2003
    Posts:
    17,561
    Likes Received:
    942
    Location:
    Massachussetts
    I'll try to help..

    First off,I only know the harness on 73-87 trucks,but I assume the 89 might be the same,other than the TBI wiring,etc..

    All the trucks I had ,have only ONE thick red wire bolting to the output terminal on the altenator..it runs along the passenger side valve cover,and splices into the harness behind the engine..like a "Y"..one side goes to that "junction block" thing near the brake booster..the other one splits into two red wires,both with fusible links,and bolt behind the positive battery cable on the solenoid at the starter..

    (how do I know this??..because nearly ALL the GM trucks I've owned FRIED that wire,due to it running thru that retarted "tube" bolted 1" from the red hot exhaust manifold!.(and despite having fusible links,it melts into ALL the other wires in that black plastic "loom" too!:angry1: )

    .I ran those wires that USED to be there right to the battery positive,right AT the battery instead!..just like GM USED to,until 1972!..WHY the retard who moved it to the starter did,is beyond me..it WASN'T broke,WHY did the have to "fix" it??:screwy: :angry1: ...I wish they'ed leave things that worked FINE ALONE!!:crazy:
     
  3. mouse

    mouse 1/2 ton status

    Joined:
    Nov 10, 2003
    Posts:
    1,448
    Likes Received:
    0
    Location:
    Great Falls Mt
    Good idea, I'll just route to the battery. BTW, the alternator is on the drivers side on the '89. I'll post a pic from the burb before I tore it apart.

    cables.JPG
     

Share This Page