Dismiss Notice

Welcome To CK5!

Registering is free and easy! Hope to see you on the forums soon.

Score a FREE t-shirt and membership sticker when you sign up for a Premium Membership and choose the recurring plan.

Rear Main Seal

Discussion in '1973-1991 K5 Blazer | Truck | Suburban' started by Jimbo, Jul 19, 2000.

  1. Jimbo

    Jimbo Registered Member

    Joined:
    Feb 17, 2000
    Posts:
    23
    Likes Received:
    0
    What would cause the rear main seal to keep blowing...

    I replaced it about 4 months ago.

    I spent this past weekend rebuilding the front end(ball joints, wheel bearings) and such.

    Had to shoot down to Panama City, Fl and halph way down there noticed a drip under the beast and sure enough that damn thing blew like a cheap (&#*&!!!!

    thanks, Jimbo
     
  2. Waxer

    Waxer 1/2 ton status Author

    Joined:
    Feb 17, 2000
    Posts:
    1,857
    Likes Received:
    0
    Location:
    Long Beach, CA.
    Are you positive its the rear main? I had a leak back there thinking it was the rear main, I found that the oil pressure sending unit was leaking, and dripping all the way down making it look like it was the rear main or oil pan.
     
  3. Blazer1970

    Blazer1970 1/2 ton status

    Joined:
    Feb 17, 2000
    Posts:
    1,600
    Likes Received:
    0
    Location:
    Old Mission, MI
    Valve covers also often leak at the back, and drip down the motor.

    Tim

    1970 Blazer CST 4X4 350 SM465 NP205
    1987 Suburban 4X4 350
    1988 Chevy Pickup 4X4 350
     
  4. blazer72

    blazer72 1/2 ton status

    Joined:
    Apr 13, 2000
    Posts:
    939
    Likes Received:
    0
    Location:
    KCMO
    You say it was replace By you! wa the motor pulled? was a rope seal used or a poly one?

    I understand the jeep thing I drive a BLAZER!!

    Ken
     

Share This Page